aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-workspace/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-09 21:47:17 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-11 15:14:35 -0300
commit106b259776d3268fc532212e30ba036dbca657d7 (patch)
tree82372346837d1c1cc497b345578d61ab1b076671 /community/plasma-workspace/APKBUILD
parenta74d92854a614136cffbbc4f95d4610a6d0ab597 (diff)
downloadaports-106b259776d3268fc532212e30ba036dbca657d7.tar.bz2
aports-106b259776d3268fc532212e30ba036dbca657d7.tar.xz
community/plasma-workspace: move from testing
Diffstat (limited to 'community/plasma-workspace/APKBUILD')
-rw-r--r--community/plasma-workspace/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/plasma-workspace/APKBUILD b/community/plasma-workspace/APKBUILD
new file mode 100644
index 0000000000..09c8486eca
--- /dev/null
+++ b/community/plasma-workspace/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=plasma-workspace
+pkgver=5.16.5
+pkgrel=1
+pkgdesc="KDE Plasma Workspace"
+arch="all !ppc64le !s390x" # Limited by libksysguard -> qt5-qtwebengine
+url="https://www.kde.org/workspaces/plasmadesktop/"
+license="(GPL-2.0-only OR GPL-3.0-only) AND LGPL-2.1-or-later AND GPL-2.0-or-later AND MIT AND LGPL-2.1-only AND LGPL-2.0-or-later AND (LGPL-2.1-only OR LGPL-3.0-only) AND LGPL-2.0-only"
+depends="tzdata qt5-qtquickcontrols kirigami2 kinit qt5-qttools kwin kactivitymanagerd milou plasma-integration qtchooser kded"
+depends_dev="plasma-framework-dev krunner-dev kjsembed-dev knotifyconfig-dev kdesu-dev knewstuff-dev kwallet-dev kidletime-dev kdeclarative-dev ki18n-dev kcmutils-dev ktextwidgets-dev kdelibs4support-dev kcrash-dev kglobalaccel-dev kdbusaddons-dev kwayland-dev kcoreaddons-dev kded-dev libksysguard-dev kpackage-dev kscreenlocker-dev phonon-dev zlib-dev kitemmodels-dev networkmanager-qt-dev baloo-dev ktexteditor-dev kwin-dev kholidays-dev prison-dev gpsd-dev iso-codes-dev"
+makedepends="$depends_dev extra-cmake-modules kdoctools-dev libxtst-dev"
+checkdepends="xvfb-run"
+source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-libs $pkgname-doc $pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ # nightcolortest requires running dbus
+ # testdesktop is broken
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(nightcolortest|testdesktop)"
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+
+ install -Dm644 plasmawayland.desktop "$pkgdir"/usr/share/wayland-sessions/plasmawayland.desktop
+}
+sha512sums="e55e89b6a8e3dcf68bb7ad4f62f284cd819c7461eff1269f84df086a2516401c26363cc6c3c8e6cc8e27788222b3ed81098d765a25e5d96d9274e3b342816369 plasma-workspace-5.16.5.tar.xz"