aboutsummaryrefslogtreecommitdiffstats
path: root/community/pngcrush
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-08 06:20:17 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-08 15:03:35 +0000
commit647ec44605cba4ede4ec0ccf410fd0712b8c2c8c (patch)
tree5c5e716a54d44e8a61cf6d715559ef2b74f6964b /community/pngcrush
parent609a540e37fa65f8fcb15adc3bb6a347058b0338 (diff)
downloadaports-647ec44605cba4ede4ec0ccf410fd0712b8c2c8c.tar.bz2
aports-647ec44605cba4ede4ec0ccf410fd0712b8c2c8c.tar.xz
community/pngcrush: modernize
Diffstat (limited to 'community/pngcrush')
-rw-r--r--community/pngcrush/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/community/pngcrush/APKBUILD b/community/pngcrush/APKBUILD
index 19948ec7c7..6f60357beb 100644
--- a/community/pngcrush/APKBUILD
+++ b/community/pngcrush/APKBUILD
@@ -6,22 +6,19 @@ pkgrel=0
pkgdesc="PNG recompression utility"
url="http://pmt.sourceforge.net/pngcrush/"
arch="all"
-license="zlib"
-depends=""
+license="Zlib"
makedepends="zlib-dev libpng-dev"
-source="https://downloads.sourceforge.net/pmt/${pkgname}-${pkgver}-nolib.tar.xz"
+source="https://downloads.sourceforge.net/pmt/pngcrush-$pkgver-nolib.tar.xz"
builddir="$srcdir/$pkgname-$pkgver-nolib"
build() {
- cd "$builddir"
- make CC="${CC:-gcc}" \
+ make CC="$CC" \
CFLAGS="$CFLAGS" \
LDFLAGS="$LDFLAGS"
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
sha512sums="c073d573e9b13b72fa39b178271ce65d1a19fef35943ef0a9e6121a5c66d9db212aaad38ab777c5b44e20a107eb677003acbdb4a354bcb2dc40f535a97d9df0e pngcrush-1.8.13-nolib.tar.xz"