aboutsummaryrefslogtreecommitdiffstats
path: root/community/pngquant
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-06-12 19:24:26 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-12 19:48:28 +0000
commit0fbbed84732bfd5b5b65263e0f931b0d1cdd121a (patch)
treed388dd0e7023d5d86c3a18913f5c63ef5e2f2f5e /community/pngquant
parent5de815a43fb3fc967afe20b9a22ce2b07a1252f1 (diff)
downloadaports-0fbbed84732bfd5b5b65263e0f931b0d1cdd121a.tar.bz2
aports-0fbbed84732bfd5b5b65263e0f931b0d1cdd121a.tar.xz
community/pngquant: move from testing
Diffstat (limited to 'community/pngquant')
-rw-r--r--community/pngquant/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/community/pngquant/APKBUILD b/community/pngquant/APKBUILD
new file mode 100644
index 0000000000..bd62dec31e
--- /dev/null
+++ b/community/pngquant/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=pngquant
+pkgver=2.9.1
+pkgrel=0
+pkgdesc="Lossy PNG compressor"
+url="https://pngquant.org/"
+arch="all"
+license="GPL"
+makedepends="libpng-dev lcms2-dev bash"
+subpackages="$pkgname-doc"
+source="http://pngquant.org/$pkgname-$pkgver-src.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+sha512sums="c2f47627395257147857c556e030681e05213eed52d72c314a43e09ce9a84a491acbda2eabae6c3b79a02bde9bdb3a84edd573e63cdd207866f6238322400786 pngquant-2.9.1-src.tar.gz"