aboutsummaryrefslogtreecommitdiffstats
path: root/community/pngquant
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-23 19:33:48 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-23 19:34:04 +0000
commit1454fbb94a20d4c148e247288ccf681bec92e70f (patch)
tree8810c12bb3667951f77e6d0442fb4c5310ecebd4 /community/pngquant
parent9ba6b221e1dbddc1cd1c90f6d223ffda14ce201b (diff)
downloadaports-1454fbb94a20d4c148e247288ccf681bec92e70f.tar.bz2
aports-1454fbb94a20d4c148e247288ccf681bec92e70f.tar.xz
community/pngquant: add simple check
As upstream doesn't provide a suite test, add a simple --help test.
Diffstat (limited to 'community/pngquant')
-rw-r--r--community/pngquant/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/community/pngquant/APKBUILD b/community/pngquant/APKBUILD
index 64a383d846..b84b228768 100644
--- a/community/pngquant/APKBUILD
+++ b/community/pngquant/APKBUILD
@@ -2,13 +2,12 @@
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=pngquant
pkgver=2.11.2
-pkgrel=0
+pkgrel=1
pkgdesc="Lossy PNG compressor"
url="https://pngquant.org/"
arch="all"
license="GPL"
makedepends="libpng-dev lcms2-dev bash"
-options="!check" # No tests provided
subpackages="$pkgname-doc"
source="http://pngquant.org/$pkgname-$pkgver-src.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
@@ -19,6 +18,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ ./pngquant --help > /dev/null
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install