aboutsummaryrefslogtreecommitdiffstats
path: root/community/portablexdr
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 10:29:27 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 10:56:27 +0000
commit6ccb7e4a989de9785c99ea96ca6b35ac4da0a7fa (patch)
tree8b109c5114ba456e2a4425b017cbb48d569b65ab /community/portablexdr
parent05d8679cf7535fce20297e7d6e96bbc6bdd8ae95 (diff)
downloadaports-6ccb7e4a989de9785c99ea96ca6b35ac4da0a7fa.tar.bz2
aports-6ccb7e4a989de9785c99ea96ca6b35ac4da0a7fa.tar.xz
community/portablexdr: moved from testing
Diffstat (limited to 'community/portablexdr')
-rw-r--r--community/portablexdr/APKBUILD71
-rw-r--r--community/portablexdr/portablexdr-4.9.1-no-config-h.patch6
-rw-r--r--community/portablexdr/portablexdr-build-use-intptr_t-and-uintptr_t-to-cast-ptr-to-int.patch79
-rw-r--r--community/portablexdr/quad-types.patch13
4 files changed, 169 insertions, 0 deletions
diff --git a/community/portablexdr/APKBUILD b/community/portablexdr/APKBUILD
new file mode 100644
index 0000000000..19829bf016
--- /dev/null
+++ b/community/portablexdr/APKBUILD
@@ -0,0 +1,71 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=portablexdr
+pkgver=4.9.1
+pkgrel=1
+pkgdesc="external data representation (XDR) library"
+url="http://people.redhat.com/~rjones/portablexdr/"
+arch="all"
+license="GPLv2+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev libtool"
+install=""
+subpackages="$pkgname-dev $pkgname-rpcgen"
+source="http://people.redhat.com/~rjones/portablexdr/files/portablexdr-$pkgver.tar.gz
+ portablexdr-4.9.1-no-config-h.patch
+ portablexdr-build-use-intptr_t-and-uintptr_t-to-cast-ptr-to-int.patch
+ quad-types.patch
+"
+
+_builddir="$srcdir"/portablexdr-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+
+ # rename byteswap.h so it does not gets pulled in by uclibc headers
+ mv byteswap.h _byteswap.h
+ sed -i -e 's/byteswap\.h/_byteswap.h/g' \
+ Makefile.in *.c
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ ln -s portable-rpcgen "$pkgdir"/usr/bin/rpcgen
+}
+
+rpcgen() {
+ pkgdesc="Portable rpcgen"
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+md5sums="949e6dc9815590e5688f18bfdd2a98f9 portablexdr-4.9.1.tar.gz
+e5e44853226f8e756aa499299404d505 portablexdr-4.9.1-no-config-h.patch
+6d8528d20edd2db618fad96f2afcd926 portablexdr-build-use-intptr_t-and-uintptr_t-to-cast-ptr-to-int.patch
+c668a7d516c8096651cef92bdf6835b6 quad-types.patch"
+sha256sums="5cf4bdd153cf4d44eaf10b725f451d0cfadc070b4b9a9ccfb64094b8f78de72c portablexdr-4.9.1.tar.gz
+75cec27cba9d667d4e137f13fb8e66a3a91344f458691e93d13928f5891216b9 portablexdr-4.9.1-no-config-h.patch
+7919d9157537552c34047f8423d3e923fcb79d097b796141d28e05d2c5b8b6e0 portablexdr-build-use-intptr_t-and-uintptr_t-to-cast-ptr-to-int.patch
+2a75fff6a66cc99af987fe928600c38eb17bb5163e8346a7feafa7374c542ce2 quad-types.patch"
+sha512sums="47f2402e7ed9f2f518e2a45e76e8ad6c4b1e7ae1bd9408ca4dca3d0883697e755460ee64eef405e23b1840ad3b89ad54555bdf59dc8bae3cd8b67086d6ab3b1f portablexdr-4.9.1.tar.gz
+4d7dd2c6a40438ca9df8da93dad91295802ddd0cf51f4c2710a0213c34255f119a1c397c8aee9ffb6499baba2c3a39ce2f7ef5a46a2ce87cd8e881f8ab41d1c2 portablexdr-4.9.1-no-config-h.patch
+f650a12897256a7194ec125dcac008b4a75b1907bfddcc34c4d23f40f93718072c9958b9eca7afeb1e356a64b5189d71077f765b5592b847d3473b2ee346ae8f portablexdr-build-use-intptr_t-and-uintptr_t-to-cast-ptr-to-int.patch
+8057db443cdb956945a40c2cf9d1f4d59086bd8affc819e36be146c50a7109bf18bd47e1ff69979d1e9187413d37836426b02cec6761987cf1c3483f6ed1f911 quad-types.patch"
diff --git a/community/portablexdr/portablexdr-4.9.1-no-config-h.patch b/community/portablexdr/portablexdr-4.9.1-no-config-h.patch
new file mode 100644
index 0000000000..5307966a5b
--- /dev/null
+++ b/community/portablexdr/portablexdr-4.9.1-no-config-h.patch
@@ -0,0 +1,6 @@
+--- portablexdr-4.9.1/rpc/rpc.h.old 2011-07-05 14:36:57.938389205 +0100
++++ portablexdr-4.9.1/rpc/rpc.h 2011-07-05 14:37:04.213519063 +0100
+@@ -1,3 +1,2 @@
+-#include "config.h"
+ #include <rpc/types.h>
+ #include <rpc/xdr.h>
diff --git a/community/portablexdr/portablexdr-build-use-intptr_t-and-uintptr_t-to-cast-ptr-to-int.patch b/community/portablexdr/portablexdr-build-use-intptr_t-and-uintptr_t-to-cast-ptr-to-int.patch
new file mode 100644
index 0000000000..847ca15910
--- /dev/null
+++ b/community/portablexdr/portablexdr-build-use-intptr_t-and-uintptr_t-to-cast-ptr-to-int.patch
@@ -0,0 +1,79 @@
+From a7461e1430fcc26b02457f7b8f53dc423c062e1e Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Marc-Andr=C3=A9=20Lureau?= <marcandre.lureau@redhat.com>
+Date: Mon, 23 Jan 2012 19:31:10 +0100
+Subject: [PATCH] build: use intptr_t and uintptr_t to cast ptr to int
+
+---
+ xdr_mem.c | 2 +-
+ xdr_rec.c | 16 ++++++++--------
+ 2 files changed, 9 insertions(+), 9 deletions(-)
+
+diff --git a/xdr_mem.c b/xdr_mem.c
+index 701cad2..f8a2d3a 100644
+--- a/xdr_mem.c
++++ b/xdr_mem.c
+@@ -169,7 +169,7 @@ xdrmem_setpos(xdrs, pos)
+ register caddr_t newaddr = xdrs->x_base + pos;
+ register caddr_t lastaddr = xdrs->x_private + xdrs->x_handy;
+
+- if ((long)newaddr > (long)lastaddr)
++ if ((intptr_t)newaddr > (intptr_t)lastaddr)
+ return (FALSE);
+ xdrs->x_private = newaddr;
+ xdrs->x_handy = lastaddr - newaddr;
+diff --git a/xdr_rec.c b/xdr_rec.c
+index 6859c42..a0d34c6 100644
+--- a/xdr_rec.c
++++ b/xdr_rec.c
+@@ -173,7 +173,7 @@ xdrrec_create(xdrs, sendsize, recvsize, tcp_handle, readit, writeit)
+ return;
+ }
+ for (rstrm->out_base = rstrm->the_buffer;
+- (long) rstrm->out_base % BYTES_PER_XDR_UNIT != 0;
++ (intptr_t) rstrm->out_base % BYTES_PER_XDR_UNIT != 0;
+ rstrm->out_base++);
+ rstrm->in_base = rstrm->out_base + sendsize;
+ /*
+@@ -472,12 +472,12 @@ xdrrec_endofrecord(xdrs, sendnow)
+ register u_long len; /* fragment length */
+
+ if (sendnow || rstrm->frag_sent ||
+- ((u_long)rstrm->out_finger + sizeof(u_long) >=
+- (u_long)rstrm->out_boundry)) {
++ ((uintptr_t)rstrm->out_finger + sizeof(u_long) >=
++ (uintptr_t)rstrm->out_boundry)) {
+ rstrm->frag_sent = FALSE;
+ return (flush_out(rstrm, TRUE));
+ }
+- len = (u_long)(rstrm->out_finger) - (u_long)(rstrm->frag_header) -
++ len = (uintptr_t)(rstrm->out_finger) - (uintptr_t)(rstrm->frag_header) -
+ sizeof(u_long);
+ *(rstrm->frag_header) = htonl((u_long)len | LAST_FRAG);
+ rstrm->frag_header = (u_long *)rstrm->out_finger;
+@@ -495,11 +495,11 @@ flush_out(rstrm, eor)
+ bool_t eor;
+ {
+ register u_long eormask = (eor == TRUE) ? LAST_FRAG : 0;
+- register u_long len = (u_long)(rstrm->out_finger) -
+- (u_long)(rstrm->frag_header) - sizeof(u_long);
++ register u_long len = (uintptr_t)(rstrm->out_finger) -
++ (uintptr_t)(rstrm->frag_header) - sizeof(u_long);
+
+ *(rstrm->frag_header) = htonl(len | eormask);
+- len = (u_long)(rstrm->out_finger) - (u_long)(rstrm->out_base);
++ len = (uintptr_t)(rstrm->out_finger) - (uintptr_t)(rstrm->out_base);
+ if ((*(rstrm->writeit))(rstrm->tcp_handle, rstrm->out_base, (int)len)
+ != (int)len)
+ return (FALSE);
+@@ -517,7 +517,7 @@ fill_input_buf(rstrm)
+ register int len;
+
+ where = rstrm->in_base;
+- i = (long) rstrm->in_boundry % BYTES_PER_XDR_UNIT;
++ i = (intptr_t) rstrm->in_boundry % BYTES_PER_XDR_UNIT;
+ where += i;
+ len = rstrm->in_size - i;
+ if ((len = (*(rstrm->readit))(rstrm->tcp_handle, where, len)) == -1)
+--
+1.7.7.5
+
diff --git a/community/portablexdr/quad-types.patch b/community/portablexdr/quad-types.patch
new file mode 100644
index 0000000000..72cb0691e7
--- /dev/null
+++ b/community/portablexdr/quad-types.patch
@@ -0,0 +1,13 @@
+--- ./rpc/types.h.orig
++++ ./rpc/types.h
+@@ -41,8 +41,8 @@
+ typedef uint16_t u_short;
+ typedef uint32_t u_int;
+ typedef unsigned long u_long;
+-typedef uint64_t u_quad_t;
+-typedef int64_t quad_t;
++//typedef uint64_t u_quad_t;
++//typedef int64_t quad_t;
+ typedef char * caddr_t;
+
+ #ifndef TRUE