aboutsummaryrefslogtreecommitdiffstats
path: root/community/portablexdr
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-29 23:10:24 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-29 23:10:24 +0000
commitd32ada8840a5d60fdb00bd8e77e08c56a7320a2f (patch)
tree14d92467fb6ed60cc4ab63a3710e9c4e3c737269 /community/portablexdr
parent223dd5c6c08ab2ae97083dfa1c32fe52a2b74f37 (diff)
downloadaports-d32ada8840a5d60fdb00bd8e77e08c56a7320a2f.tar.bz2
aports-d32ada8840a5d60fdb00bd8e77e08c56a7320a2f.tar.xz
community/portablexdr: update config guess (build fix aarch64)
Diffstat (limited to 'community/portablexdr')
-rw-r--r--community/portablexdr/APKBUILD22
1 files changed, 7 insertions, 15 deletions
diff --git a/community/portablexdr/APKBUILD b/community/portablexdr/APKBUILD
index 19829bf016..e011685125 100644
--- a/community/portablexdr/APKBUILD
+++ b/community/portablexdr/APKBUILD
@@ -17,24 +17,16 @@ source="http://people.redhat.com/~rjones/portablexdr/files/portablexdr-$pkgver.t
quad-types.patch
"
-_builddir="$srcdir"/portablexdr-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+builddir="$srcdir"/portablexdr-$pkgver
- # rename byteswap.h so it does not gets pulled in by uclibc headers
- mv byteswap.h _byteswap.h
- sed -i -e 's/byteswap\.h/_byteswap.h/g' \
- Makefile.in *.c
+prepare() {
+ cd "$builddir"
+ default_prepare || return 1
+ update_config_guess || return 1
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
@@ -46,7 +38,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
ln -s portable-rpcgen "$pkgdir"/usr/bin/rpcgen
}