aboutsummaryrefslogtreecommitdiffstats
path: root/community/pulseaudio-ctl
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-01-09 08:55:17 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-09 08:55:17 +0100
commitf4c6b09cbd4324d79763032369b3f0c4bdc8077e (patch)
tree04ac3c758a5bb0818d7149d8f769a689b070b859 /community/pulseaudio-ctl
parentbebdc1a276908297b4cda6145e39c95e1b09abbd (diff)
downloadaports-f4c6b09cbd4324d79763032369b3f0c4bdc8077e.tar.bz2
aports-f4c6b09cbd4324d79763032369b3f0c4bdc8077e.tar.xz
community/pulseaudio-ctl: move from testing
Diffstat (limited to 'community/pulseaudio-ctl')
-rw-r--r--community/pulseaudio-ctl/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/pulseaudio-ctl/APKBUILD b/community/pulseaudio-ctl/APKBUILD
new file mode 100644
index 0000000000..07c72f5ed2
--- /dev/null
+++ b/community/pulseaudio-ctl/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=pulseaudio-ctl
+pkgver=1.67
+pkgrel=0
+pkgdesc="Control pulseaudio volume from the shell or mapped to keyboard shortcuts"
+options="!check" # No testsuite
+url="https://github.com/graysky2/pulseaudio-ctl"
+arch="noarch"
+license="MIT"
+depends="bash pulseaudio-utils"
+subpackages="
+ $pkgname-doc
+ $pkgname-zsh-completion:zshcomp:noarch
+ "
+source="$pkgname-$pkgver.tar.gz::https://github.com/graysky2/pulseaudio-ctl/archive/v$pkgver.tar.gz"
+
+build() {
+ make
+}
+
+package() {
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+zshcomp() {
+ depends=""
+ pkgdesc="Zsh compltions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+
+ mkdir -p "$subpkgdir"/usr/share/zsh
+ mv "$pkgdir"/usr/share/zsh/site-functions "$subpkgdir"/usr/share/zsh
+ rmdir -p "$pkgdir"/usr/share/zsh 2>/dev/null || :
+}
+
+sha512sums="5ea1cbfd87cf073de46b6fd9953a3c7b9c6969da46103dd5dfc56aa3f179b2ba36ade5db7ca47d204f0f60ac02020f1a4f2dd58bbaf010f9a99780702295418c pulseaudio-ctl-1.67.tar.gz"