aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-argh
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-23 00:55:30 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-23 00:55:30 +0000
commit930ee52dac192d9d3a404820855f8c9cd7a98c56 (patch)
tree53485b3ad3e0f747a489fc4d28a43b400e50e7d8 /community/py-argh
parent37539843c397679ac01c8f590d634db31f18be49 (diff)
downloadaports-930ee52dac192d9d3a404820855f8c9cd7a98c56.tar.bz2
aports-930ee52dac192d9d3a404820855f8c9cd7a98c56.tar.xz
community/py-argh: modernize and add check
Diffstat (limited to 'community/py-argh')
-rw-r--r--community/py-argh/APKBUILD28
1 files changed, 11 insertions, 17 deletions
diff --git a/community/py-argh/APKBUILD b/community/py-argh/APKBUILD
index b36232081a..13aaa1580e 100644
--- a/community/py-argh/APKBUILD
+++ b/community/py-argh/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py-argh
_pkgname=argh
pkgver=0.26.2
-pkgrel=0
+pkgrel=1
pkgdesc="A Python argparse wrapper"
url="https://github.com/neithere/argh/"
arch="noarch"
@@ -15,27 +15,21 @@ install=""
subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ cd "$builddir"
+ python2 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py test
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="edda25f3f0164a963dd89c0e3c619973 argh-0.26.2.tar.gz"
-sha256sums="e9535b8c84dc9571a48999094fda7f33e63c3f1b74f3e5f3ac0105a58405bb65 argh-0.26.2.tar.gz"
sha512sums="90382900d5cec9629dacb4459a2c9491d1425b66fa3f90d7cbf511dec846a99dbb9424f3e08f0c006da48fbf9c067078705be70b314700541fd800630e4b1707 argh-0.26.2.tar.gz"