aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-argh
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-07-12 12:46:18 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-07-12 12:46:18 +0000
commitaae0998fb8e4090eb87b91204a26fb99031508a5 (patch)
treefb0fd93b19299f636bd39ac390ebef8bdbe29c53 /community/py-argh
parent473cb9135da3635f6bcc8056d1c5d9e30f1f2119 (diff)
downloadaports-aae0998fb8e4090eb87b91204a26fb99031508a5.tar.bz2
aports-aae0998fb8e4090eb87b91204a26fb99031508a5.tar.xz
community/py-argh: moved from testing. Upgraded to 0.26.2
Diffstat (limited to 'community/py-argh')
-rw-r--r--community/py-argh/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/py-argh/APKBUILD b/community/py-argh/APKBUILD
new file mode 100644
index 0000000000..8d087f6a61
--- /dev/null
+++ b/community/py-argh/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-argh
+_pkgname=argh
+pkgver=0.26.2
+pkgrel=0
+pkgdesc="A Python argparse wrapper"
+url="http://github.com/neithere/argh/"
+arch="noarch"
+license="LGPL3+"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="edda25f3f0164a963dd89c0e3c619973 argh-0.26.2.tar.gz"
+sha256sums="e9535b8c84dc9571a48999094fda7f33e63c3f1b74f3e5f3ac0105a58405bb65 argh-0.26.2.tar.gz"
+sha512sums="90382900d5cec9629dacb4459a2c9491d1425b66fa3f90d7cbf511dec846a99dbb9424f3e08f0c006da48fbf9c067078705be70b314700541fd800630e4b1707 argh-0.26.2.tar.gz"