aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-argparse
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-04-20 15:26:00 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-04-20 15:27:47 +0000
commitefb9642f0408d71f0e850c8ff0859dbf2df87655 (patch)
treeaafd94e94b5d30db0858aaee4aac7b8d0fa68e1e /community/py-argparse
parent3ef3d313e7b26ee9c7c9ca2425f097bd365cb771 (diff)
downloadaports-efb9642f0408d71f0e850c8ff0859dbf2df87655.tar.bz2
aports-efb9642f0408d71f0e850c8ff0859dbf2df87655.tar.xz
community/py-argparse: new aport. Fixes #7179
Directly on community since it's a new dependency for certbot package
Diffstat (limited to 'community/py-argparse')
-rw-r--r--community/py-argparse/APKBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/community/py-argparse/APKBUILD b/community/py-argparse/APKBUILD
new file mode 100644
index 0000000000..651916a9ad
--- /dev/null
+++ b/community/py-argparse/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-argparse
+_pkgname=argparse
+pkgver=1.4.0
+pkgrel=0
+pkgdesc="Python command-line parsing library"
+url="https://pypi.python.org/pypi/argparse/"
+arch="noarch"
+license="MIT"
+depends="python"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://pypi.python.org/packages/source/a/argparse/argparse-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}" ## remove if there are no common Python dependencies
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}" ## remove if there are no common Python dependencies
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python" ## remove if arch isn't noarch
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+sha512sums="9941f9d26c43169f947c9efadda6239349e1f9df80ff5fcdba3070bc7b43c43ab6bb4b7f0c7eee8e5d06231a17a7e9ee9eb73c7a9bb68ebe5d13f879686d61b2 argparse-1.4.0.tar.gz"