aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-augeas
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2019-01-26 21:53:19 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2019-01-26 21:53:58 +0000
commitb9b73535924c61fc24102d8693765aa5eb3f818e (patch)
treea9848984ac8104050027cd9da208c71573417ef2 /community/py-augeas
parentdb9db889c088962ebc0c4ae2fa1085d7482c410d (diff)
downloadaports-b9b73535924c61fc24102d8693765aa5eb3f818e.tar.bz2
aports-b9b73535924c61fc24102d8693765aa5eb3f818e.tar.xz
testing/py-augeas: move to community
Needed for certbot
Diffstat (limited to 'community/py-augeas')
-rw-r--r--community/py-augeas/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/community/py-augeas/APKBUILD b/community/py-augeas/APKBUILD
new file mode 100644
index 0000000000..51ed80a623
--- /dev/null
+++ b/community/py-augeas/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-augeas
+_pkgname=python-augeas
+pkgver=1.0.3
+pkgrel=0
+pkgdesc="Pure python bindings for augeas"
+url="https://pypi.python.org/pypi/python-augeas"
+arch="noarch"
+license="GPL-2.1"
+depends="augeas-libs py-cffi"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+check() {
+ cd "$builddir"/test
+ python2 test_augeas.py
+ python3 test_augeas.py
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python=$1
+ pkgdesc="$pkgdesc - $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+sha512sums="737b41e7bb438d80da75b55714c3f0b1706a4b2cacddd20fadf855bc3044e532f4079319b3775032e6f6009cf7f282af33fdf583332772b443a6c2d4925639fa python-augeas-1.0.3.tar.gz"