aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-cheetah
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-05 06:50:17 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-05 08:13:16 -0300
commitb35f7704e9678d354fd02a296a587fe2b323bf20 (patch)
treeafd6d29600157b484520ed8d8bfa313a72edfc97 /community/py-cheetah
parentd2fdf1344d15989a90ac31b7a0e1b33458357944 (diff)
downloadaports-b35f7704e9678d354fd02a296a587fe2b323bf20.tar.bz2
aports-b35f7704e9678d354fd02a296a587fe2b323bf20.tar.xz
community/py-cheetah: upgrade to 3.2.3
Diffstat (limited to 'community/py-cheetah')
-rw-r--r--community/py-cheetah/APKBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/community/py-cheetah/APKBUILD b/community/py-cheetah/APKBUILD
index 90a3aa6839..7acf1db394 100644
--- a/community/py-cheetah/APKBUILD
+++ b/community/py-cheetah/APKBUILD
@@ -3,25 +3,23 @@
pkgname=py-cheetah
_pkgreal=${pkgname#py-}
_pkgname=Cheetah3
-pkgver=3.1.0
-pkgrel=1
+pkgver=3.2.3
+pkgrel=0
pkgdesc="Cheetah is a template engine and code generation tool"
url="http://www.cheetahtemplate.org/"
arch="all"
license="MIT"
-makedepends="python2-dev python3-dev py-setuptools"
+makedepends="python2-dev python3-dev py-setuptools py3-setuptools"
subpackages="py3-$_pkgreal:_py3 py2-$_pkgreal:_py2"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
python2 setup.py build
python3 setup.py build
}
check() {
- cd "$builddir"
python2 setup.py check
python3 setup.py check
}
@@ -36,12 +34,12 @@ _py2() {
depends="${depends//py-/py2-}"
_py python2
}
-
+
_py3() {
depends="${depends//py-/py3-}"
_py python3
}
-
+
_py() {
local python="$1"
pkgdesc="$pkgdesc (for $python)"
@@ -52,4 +50,4 @@ _py() {
$python setup.py install --prefix=/usr --root="$subpkgdir"
}
-sha512sums="879de1b7a333def757a1618b7c28348d8b2f43a433aa8d5d9ee501619a854c514ca4a842f741bf4d272f5cc2defa137b741d2cc9648a3fc40dc2c4ab50692fac Cheetah3-3.1.0.tar.gz"
+sha512sums="ebc735b59d61912679405469f9d509fc73bbdde51c414320994421849f4a02266d2c286c0f618cab2a592ab47ac0a4be9ec444fab75145a0c31dd0c3c39fc1e3 Cheetah3-3.2.3.tar.gz"