aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-img2pdf
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-08-11 01:28:52 +0300
committerprspkt <prspkt@protonmail.com>2019-08-11 02:08:56 +0300
commit3bb0479039ca8523e7d8b03e81640da084a8096f (patch)
tree0e235a8e5295dd2d468c0ebdce19c4996d820cb7 /community/py-img2pdf
parent081ffb64984617f2baa71c303cf00da97d42f7cd (diff)
downloadaports-3bb0479039ca8523e7d8b03e81640da084a8096f.tar.bz2
aports-3bb0479039ca8523e7d8b03e81640da084a8096f.tar.xz
community/py-img2pdf: drop python2, clarify license.
Signed-off-by: prspkt <prspkt@protonmail.com>
Diffstat (limited to 'community/py-img2pdf')
-rw-r--r--community/py-img2pdf/10-tests-import-print-function.patch8
-rw-r--r--community/py-img2pdf/APKBUILD57
2 files changed, 0 insertions, 65 deletions
diff --git a/community/py-img2pdf/10-tests-import-print-function.patch b/community/py-img2pdf/10-tests-import-print-function.patch
deleted file mode 100644
index 09e643a8ed..0000000000
--- a/community/py-img2pdf/10-tests-import-print-function.patch
+++ /dev/null
@@ -1,8 +0,0 @@
---- a/src/tests/__init__.py
-+++ b/src/tests/__init__.py
-@@ -1,3 +1,5 @@
-+from __future__ import print_function
-+
- import unittest
-
- import img2pdf
diff --git a/community/py-img2pdf/APKBUILD b/community/py-img2pdf/APKBUILD
deleted file mode 100644
index 73ffc6ea8b..0000000000
--- a/community/py-img2pdf/APKBUILD
+++ /dev/null
@@ -1,57 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
-# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
-pkgname=py-img2pdf
-pkgver=0.3.3
-pkgrel=1
-pkgdesc="Convert images to PDF via direct JPEG inclusion"
-url="https://gitlab.mister-muffin.de/josch/img2pdf"
-arch="noarch !s390x"
-license="LGPL"
-depends="py-pillow"
-_py2_depends="py-enum34"
-makedepends="python2-dev python3-dev py-setuptools"
-checkdepends="py-pdfrw"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="https://pypi.python.org/packages/source/i/img2pdf/img2pdf-$pkgver.tar.gz
- 10-tests-import-print-function.patch
- "
-builddir="$srcdir/img2pdf-$pkgver"
-
-build() {
- cd "$builddir"
- python2 setup.py build
- python3 setup.py build
-}
-
-check() {
- cd "$builddir"
- python2 setup.py test
- python3 setup.py test
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-} _py2_depends"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-sha512sums="234e0031d75727d2f5d2b82603bb447d9101ace81e604b6d5eb358d0b4681e209dbd737775b90b44096cf84239aac9e87e2369e0c6112a17f24ccbf10a20cdd5 img2pdf-0.3.3.tar.gz
-495bc1d41ff72615666c7e746040b6e38ee4f7f4ad2c581f4c9fa16b617484ea70b63036ea4d5b7270aa9fc64e873b47d2ba6ab5d0c05f484e2c99a3cfae2f41 10-tests-import-print-function.patch"