aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-impacket
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-23 10:41:24 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-23 10:41:24 +0000
commit1140f515941e78b811ddc78e9ddf49dc931be6b0 (patch)
treee8490737abd3f499ce396df22704a29e7842acd3 /community/py-impacket
parent0171c107ac116bb46007322133def5856239317b (diff)
downloadaports-1140f515941e78b811ddc78e9ddf49dc931be6b0.tar.bz2
aports-1140f515941e78b811ddc78e9ddf49dc931be6b0.tar.xz
community/py-impacket: added py2 subpackage, moved from testing
Diffstat (limited to 'community/py-impacket')
-rw-r--r--community/py-impacket/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/community/py-impacket/APKBUILD b/community/py-impacket/APKBUILD
new file mode 100644
index 0000000000..56d5222d5b
--- /dev/null
+++ b/community/py-impacket/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-impacket
+_pkgname=impacket
+pkgver=0.9.15
+pkgrel=1
+pkgdesc="A collection of Python classes providing access to network packets"
+url="http://code.google.com/p/impacket/"
+arch="noarch"
+license="ASL 2.0"
+depends=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages="py2-${pkgname/py-/}:_py2 $pkgname-doc"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+ install -Dm0644 "$builddir"/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+
+_py() {
+ local python=$1
+ pkgdesc="$pkgdesc - $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ _py python2
+ replaces="$pkgname"
+ depends="py2-asn1 py2-crypto"
+}
+
+doc() {
+ cd "$builddir"
+ mkdir -p "$subpkgdir"/usr/share/doc/$pkgname
+ mv impacket/testcases "$subpkgdir"/usr/share/doc/$pkgname
+ mv README.md "$subpkgdir"/usr/share/doc/$pkgname
+ install -Dm0644 LICENSE "$subpkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+md5sums="53fb6d1c375dd3ef8fff4ce2b7ff8f15 impacket-0.9.15.tar.gz"
+sha256sums="26af9c0734525448e4a8d56c9c7b05df0146497ec71101c33812f3f3503201eb impacket-0.9.15.tar.gz"
+sha512sums="1d061d19c873c58fc243bc0d49270d39a43fd3c82814862f1d4d1ac0241f162d1f3be765d0778243fd911736c4652dcdd7110ea5f86d1086b1829fa836f61b16 impacket-0.9.15.tar.gz"