aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-isort/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-08-28 13:14:12 +0300
committerprspkt <prspkt@protonmail.com>2019-08-28 13:21:33 +0300
commit3afadf938bf0c536101fedc5a4f96e7f77083e38 (patch)
treeb9b5bfc759efc9b62b3bf8f8bebcec4f9cc40313 /community/py-isort/APKBUILD
parent638fb699f27e962c01911874e3cb87dfb1a79ae7 (diff)
downloadaports-3afadf938bf0c536101fedc5a4f96e7f77083e38.tar.bz2
aports-3afadf938bf0c536101fedc5a4f96e7f77083e38.tar.xz
community/py-isort: drop python2
Signed-off-by: prspkt <prspkt@protonmail.com>
Diffstat (limited to 'community/py-isort/APKBUILD')
-rw-r--r--community/py-isort/APKBUILD51
1 files changed, 0 insertions, 51 deletions
diff --git a/community/py-isort/APKBUILD b/community/py-isort/APKBUILD
deleted file mode 100644
index e042e1ae41..0000000000
--- a/community/py-isort/APKBUILD
+++ /dev/null
@@ -1,51 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-isort
-_pkgname=isort
-pkgver=4.3.19
-pkgrel=0
-pkgdesc="A Python utility / library to sort Python imports"
-url="https://github.com/timothycrosley/isort"
-arch="noarch"
-license="MIT"
-# 3 out of 111 tests are failing. Needs upstream fix.
-options="!check"
-makedepends="python2-dev python3-dev py-setuptools pytest py3-pytest"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
-
-build() {
- python2 setup.py build
- python3 setup.py build
-}
-
-check() {
- pytest test_isort.py
- pytest-3 test_isort.py
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-sha512sums="3782f44bc7b5141105ff0e56d32e6ef80a231879d12b44c4e317209600fc0e597adf97600c17d890597e5cc31590be9d7ff2b45d0666ad518516ccb81343bb9c isort-4.3.19.tar.gz"