aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-natsort
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2018-03-15 08:03:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-15 11:49:31 +0000
commit581200ed7909233d560f1c9457c6eb3f3f99f3ab (patch)
tree654be3412bbdd903ddec2b75eacd4b4f08cdef34 /community/py-natsort
parent0dc49909de6c0b2784baba24654575e1005f1b62 (diff)
downloadaports-581200ed7909233d560f1c9457c6eb3f3f99f3ab.tar.bz2
aports-581200ed7909233d560f1c9457c6eb3f3f99f3ab.tar.xz
community/py-natsort: upgrade to 5.2.0
Diffstat (limited to 'community/py-natsort')
-rw-r--r--community/py-natsort/APKBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/community/py-natsort/APKBUILD b/community/py-natsort/APKBUILD
index da05903e0f..99879cf260 100644
--- a/community/py-natsort/APKBUILD
+++ b/community/py-natsort/APKBUILD
@@ -2,12 +2,14 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-natsort
_pkgname=natsort
-pkgver=5.1.1
+pkgver=5.2.0
pkgrel=0
pkgdesc="A module for natural sorting"
url="https://github.com/SethMMorton/natsort"
arch="noarch"
license="MIT"
+# Dependencies to run tests are not ready yet
+options="!check"
makedepends="python2-dev python3-dev py-setuptools"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
@@ -15,8 +17,14 @@ builddir="$srcdir"/$_pkgname-$pkgver
build() {
cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ pytest natsort
+ pytest-3 natsort
}
package() {
@@ -42,4 +50,4 @@ _py() {
$python setup.py install --prefix=/usr --root="$subpkgdir"
}
-sha512sums="a5e3c1a21cdd96862f1c8c0d84dcccef4737d2480ba721e016cbe52dc52df29689685e435157c0cd1c524dde2f6388aa52c1376dd727cba3d13d39bcfcf00466 natsort-5.1.1.tar.gz"
+sha512sums="7bdd80134a949aa64f9f1c0cf7ce631de614ff2c7123c69c691be8e89026bbaecf53db1b4debca989fd63df3e676168a1c555d00c8bb4ab9c7ee74c70b75c3c0 natsort-5.2.0.tar.gz"