aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-opencl/APKBUILD
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2019-05-30 21:35:29 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-31 04:52:32 +0000
commit4dabcc9affb3793d198a3848076a1402f2236954 (patch)
treeb93593ea4d370b6c906f740ef22df53b2d86e8a8 /community/py-opencl/APKBUILD
parent6d52a132f157470e84f2fa6311433b1525349e9d (diff)
downloadaports-4dabcc9affb3793d198a3848076a1402f2236954.tar.bz2
aports-4dabcc9affb3793d198a3848076a1402f2236954.tar.xz
community/py-opencl: fix compiler choice and re-enable ppc64le
Closes GH-8317
Diffstat (limited to 'community/py-opencl/APKBUILD')
-rw-r--r--community/py-opencl/APKBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/community/py-opencl/APKBUILD b/community/py-opencl/APKBUILD
index 041b4e408d..e31605ed1d 100644
--- a/community/py-opencl/APKBUILD
+++ b/community/py-opencl/APKBUILD
@@ -3,10 +3,10 @@
pkgname=py-opencl
_pkgreal=${pkgname/-/}
pkgver=2018.2.5
-pkgrel=0
+pkgrel=1
pkgdesc="Python wrapper for OpenCL"
url="https://pypi.python.org/pypi/pyopencl"
-arch="all !ppc64le"
+arch="all"
license="MIT"
depends="py-mako"
makedepends="python2-dev python3-dev py-setuptools py-numpy>=1.14.3-r1 ctags
@@ -14,7 +14,8 @@ makedepends="python2-dev python3-dev py-setuptools py-numpy>=1.14.3-r1 ctags
py-pybind11 py-numpy-dev"
checkdepends="py-six py-decorator pytest py-py"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="https://files.pythonhosted.org/packages/source/${_pkgreal:0:1}/$_pkgreal/$_pkgreal-$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/${_pkgreal:0:1}/$_pkgreal/$_pkgreal-$pkgver.tar.gz
+ fix-compiler-choice.patch"
builddir="$srcdir/$_pkgreal-$pkgver"
options="!check" # tests require python-theano which isn't packed yet
@@ -52,4 +53,5 @@ check() {
python2 setup.py test
}
-sha512sums="91f9e9b15ef0dbf22440b6abf762c729e8de587966c9d9a5da8c7ac02230ef700e31056248f1d93ec7e7af6e79918d68e18139e413f3cef287ecf683ee81ac05 pyopencl-2018.2.5.tar.gz"
+sha512sums="91f9e9b15ef0dbf22440b6abf762c729e8de587966c9d9a5da8c7ac02230ef700e31056248f1d93ec7e7af6e79918d68e18139e413f3cef287ecf683ee81ac05 pyopencl-2018.2.5.tar.gz
+b6d1295f2b413d3b27a13632df1bc7b9390423622c5748bd0d929555797ee63fd9f217b132a005a3b082d9e96952115c7846eeb675e23f69d6aeea8aa57af5e1 fix-compiler-choice.patch"