aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-opencl
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-12-27 15:00:06 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-12-27 15:03:50 +0100
commit4986beb3d61bd59748b46fc3cff4568ee54f166e (patch)
tree1cab7e8cd8ab840fd090295dc143ce32ae6d5ee1 /community/py-opencl
parent7e6578439b7efb2783b51b9f80c78ff13f4ffa01 (diff)
downloadaports-4986beb3d61bd59748b46fc3cff4568ee54f166e.tar.bz2
aports-4986beb3d61bd59748b46fc3cff4568ee54f166e.tar.xz
community/py-opencl: disable check, tests are broken
`setup.py test` downloads some Python modules needed for running tests. They now fail even on the previous version, so it's probably caused by some change in one of the module downloaded on-demand. It must be fixed to not download some arbitrary modules, so the build is reproducible. pyopencl.compyte.ndarray.test_gpu_ndarray (unittest.loader.ModuleImportFailure) ... ERROR pyopencl.compyte.ndarray.test_gpu_elemwise (unittest.loader.ModuleImportFailure) ... ERROR ====================================================================== ERROR: pyopencl.compyte.ndarray.test_gpu_ndarray (unittest.loader.ModuleImportFailure) ---------------------------------------------------------------------- ImportError: Failed to import test module: pyopencl.compyte.ndarray.test_gpu_ndarray Traceback (most recent call last): File "/usr/lib/python2.7/unittest/loader.py", line 254, in _find_tests module = self._get_module_from_name(name) File "/usr/lib/python2.7/unittest/loader.py", line 232, in _get_module_from_name __import__(name) File "/home/buildozer/aports/community/py-opencl/src/pyopencl-2017.2.2/pyopencl/compyte/ndarray/test_gpu_ndarray.py", line 7, in <module> import pygpu_ndarray as gpu_ndarray ImportError: No module named pygpu_ndarray ====================================================================== ERROR: pyopencl.compyte.ndarray.test_gpu_elemwise (unittest.loader.ModuleImportFailure) ---------------------------------------------------------------------- ImportError: Failed to import test module: pyopencl.compyte.ndarray.test_gpu_elemwise Traceback (most recent call last): File "/usr/lib/python2.7/unittest/loader.py", line 254, in _find_tests module = self._get_module_from_name(name) File "/usr/lib/python2.7/unittest/loader.py", line 232, in _get_module_from_name __import__(name) File "/home/buildozer/aports/community/py-opencl/src/pyopencl-2017.2.2/pyopencl/compyte/ndarray/test_gpu_elemwise.py", line 4, in <module> import theano ImportError: No module named theano ---------------------------------------------------------------------- Ran 2 tests in 0.000s
Diffstat (limited to 'community/py-opencl')
-rw-r--r--community/py-opencl/APKBUILD1
1 files changed, 1 insertions, 0 deletions
diff --git a/community/py-opencl/APKBUILD b/community/py-opencl/APKBUILD
index c412c76e62..2c82ac90d1 100644
--- a/community/py-opencl/APKBUILD
+++ b/community/py-opencl/APKBUILD
@@ -15,6 +15,7 @@ checkdepends="py-six py-decorator pytest py-py"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/${_pkgreal:0:1}/$_pkgreal/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
+options="!check" # FIXME: tests are broken (see commit message for details)
build() {
cd "$builddir"