aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-pexpect
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-12-12 13:51:04 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-12-12 13:51:04 +0000
commit55160c96fe3d55fe1fceaa2126fbef5d71b8bbf9 (patch)
tree296b2303fba691f2ce0ec7c91d5ef3f6fc01ca19 /community/py-pexpect
parent3d02aa980347d5a8757ca21090f95e46bba73e5c (diff)
downloadaports-55160c96fe3d55fe1fceaa2126fbef5d71b8bbf9.tar.bz2
aports-55160c96fe3d55fe1fceaa2126fbef5d71b8bbf9.tar.xz
community/py-pexpect: upgrade to 4.3.1, improved APKBUILD
Diffstat (limited to 'community/py-pexpect')
-rw-r--r--community/py-pexpect/APKBUILD48
1 files changed, 28 insertions, 20 deletions
diff --git a/community/py-pexpect/APKBUILD b/community/py-pexpect/APKBUILD
index 042c2e5e4e..48416163ac 100644
--- a/community/py-pexpect/APKBUILD
+++ b/community/py-pexpect/APKBUILD
@@ -2,13 +2,13 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py-pexpect
_pkgname=${pkgname#py-}
-pkgver=4.2.1
-pkgrel=1
+pkgver=4.3.1
+pkgrel=0
pkgdesc="Make Python a better tool for controlling and automating other programs"
url="http://pexpect.readthedocs.org/en/stable"
arch="noarch"
license="MIT"
-depends=""
+depends="py-ptyprocess"
makedepends="python2-dev python3-dev py-setuptools"
subpackages="$pkgname-doc py3-$_pkgname:_py3 py2-$_pkgname:_py2"
source="$pkgname-$pkgver.tar.gz::https://github.com/pexpect/$_pkgname/archive/$pkgver.tar.gz"
@@ -16,36 +16,44 @@ builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
}
-package() {
+check() {
cd "$builddir"
- mkdir -p "$pkgdir"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ python2 setup.py check
+ python3 setup.py check
}
-_py() {
- local python=$1
- pkgdesc="$pkgdesc - $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+package() {
+ mkdir -p "$pkgdir"
}
_py2() {
- _py python2
- depends="py-ptyprocess"
replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
}
_py3() {
+ depends="${depends//py-/py3-}"
_py python3
- depends="py3-ptyprocess"
}
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
-md5sums="8ed1182f51b655c74a1bfd6bd5213210 py-pexpect-4.2.1.tar.gz"
-sha256sums="f3e36792185a7b8b332a38846daa81d7e389688b7b63b9066d39c7f31a266a51 py-pexpect-4.2.1.tar.gz"
-sha512sums="30da69e18690f00522bd2514248b1d5613e96c2737435f6b47d30389f6acfc580511db2f89e34c8932f3af32cc61b55fb6dc19f02330c3e1e5be5417c22ebdd1 py-pexpect-4.2.1.tar.gz"
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+doc() {
+ default_doc
+ cd "$builddir"
+ install -Dm644 LICENSE "$subpkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+sha512sums="efd8e1436235b2f3d1bbc018ca1779a34d5e91e84dd495259c77e08fedda425b19e81df0861b78bbd833c7fa2b7f62b41d96c20594ddfae12c33c152ca6ce061 py-pexpect-4.3.1.tar.gz"