aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-polib
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-09-26 09:29:39 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-09-26 09:29:39 +0000
commit1f0b140a99fd0410551f0e1e7a1831e5c7c6a642 (patch)
tree5fcc439df90bb9930691a24da6cdabdcc7cc7938 /community/py-polib
parent1fada8e7fb00c03b64d3db866b4cb6d8eeb5a087 (diff)
downloadaports-1f0b140a99fd0410551f0e1e7a1831e5c7c6a642.tar.bz2
aports-1f0b140a99fd0410551f0e1e7a1831e5c7c6a642.tar.xz
community/py-polib: moved from testing
Diffstat (limited to 'community/py-polib')
-rw-r--r--community/py-polib/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/py-polib/APKBUILD b/community/py-polib/APKBUILD
new file mode 100644
index 0000000000..c88e317725
--- /dev/null
+++ b/community/py-polib/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-polib
+_pkgname=polib
+pkgver=1.0.5
+pkgrel=0
+pkgdesc="A library to manipulate gettext files"
+url="http://polib.readthedocs.org/en/latest/index.html"
+arch="noarch"
+license="MIT"
+depends="python2"
+depends_dev=""
+makedepends="python2-dev"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="c11eb8ce8e1b20fff71921402b3ce241 polib-1.0.5.tar.gz"
+sha256sums="c44236823eb6227b2fab8bd9e56632a649e67a80211f85a4a2e3c85c65c8acd9 polib-1.0.5.tar.gz"
+sha512sums="3dc02801bad76dec7a5c7a8d11e14294884bf4a8f45ed73b50b960617aa1600ee2f35261dd3ecde8b1deda1c897b0a55eaf2f0f755fe429df28b1acbd9c5e7d9 polib-1.0.5.tar.gz"