aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-py
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2018-03-22 16:38:10 +0100
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-03-23 09:50:16 +0000
commit0afede9b8b4895762fafe770f631de45ea687fd2 (patch)
tree17dce841f7e2912c9d01ea5c5075c5395d4dd5b5 /community/py-py
parent4a455eb3c8627edf5ca1f03d68eed08ddd2f89fa (diff)
downloadaports-0afede9b8b4895762fafe770f631de45ea687fd2.tar.bz2
aports-0afede9b8b4895762fafe770f631de45ea687fd2.tar.xz
community/py-py: upgrade to 1.5.3
Diffstat (limited to 'community/py-py')
-rw-r--r--community/py-py/APKBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/community/py-py/APKBUILD b/community/py-py/APKBUILD
index 779cd95203..3525021adc 100644
--- a/community/py-py/APKBUILD
+++ b/community/py-py/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-py
_pkgname=py
-pkgver=1.4.34
+pkgver=1.5.3
pkgrel=0
pkgdesc="A python library with cross-python path, ini-parsing, io, code, log facilities"
url="http://pytest.org"
@@ -16,10 +16,17 @@ builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
}
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+
package() {
mkdir -p "$pkgdir"
}
@@ -43,4 +50,4 @@ _py3() {
_py python3
}
-sha512sums="2e19c82c8315274bffe0ba2c7e20ae3af95f942c40c16121ec953af186f8ff33e8f427c070e137bb04b7cc6dcc6779e35df3911c08595fd3294b5ec9897706e1 py-1.4.34.tar.gz"
+sha512sums="243c0da94c439163257c525ef00b30fd6d8add5897121ee0b1f19476b50f18823ce2b99a5ab27a9cf47598b538758d0534060123dce0820d2a65d98046548c96 py-1.5.3.tar.gz"