aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-py
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-09 03:48:07 +0000
committerJakub Jirutka <jakub@jirutka.cz>2016-11-09 21:00:35 +0100
commit368fa5991b6fc0ae099bd9957c0d56d2a3b17e17 (patch)
tree2e45e8145f09355b0f4881e0b01d6e9750d1d5d3 /community/py-py
parent97caeb21e4794a9d7304949084e64b794c30a80b (diff)
downloadaports-368fa5991b6fc0ae099bd9957c0d56d2a3b17e17.tar.bz2
aports-368fa5991b6fc0ae099bd9957c0d56d2a3b17e17.tar.xz
community/py-py: new aport (required for community/pytest)
http://pytest.org A python library with cross-python path, ini-parsing, io, code, log facilities
Diffstat (limited to 'community/py-py')
-rw-r--r--community/py-py/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/community/py-py/APKBUILD b/community/py-py/APKBUILD
new file mode 100644
index 0000000000..9d8f23b6a6
--- /dev/null
+++ b/community/py-py/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-py
+_pkgname=py
+pkgver=1.4.31
+pkgrel=0
+pkgdesc="A python library with cross-python path, ini-parsing, io, code, log facilities"
+url="http://pytest.org"
+arch="noarch"
+license="MIT"
+depends=""
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+md5sums="5d2c63c56dc3f2115ec35c066ecd582b py-1.4.31.tar.gz"
+sha256sums="a6501963c725fc2554dabfece8ae9a8fb5e149c0ac0a42fd2b02c5c1c57fc114 py-1.4.31.tar.gz"
+sha512sums="fd0f4f509d81beb8e5cdb5a8d5d7d40d8a74737c017c915b0630ce740868c32fbf1af4a01dec2ae998e5a9516578e8404ad2b8d966606919767ae25f27eb0b0d py-1.4.31.tar.gz"