aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-pykka
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-05-16 16:57:32 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-21 11:04:09 +0000
commit403823ee875d7d9fabb5aed22e967127b79b5eda (patch)
treec6136253c568b20e35d7229e40c68df089178325 /community/py-pykka
parent10a4515a1b78769a8bad24d3b7ff85ae74ed6914 (diff)
downloadaports-403823ee875d7d9fabb5aed22e967127b79b5eda.tar.bz2
aports-403823ee875d7d9fabb5aed22e967127b79b5eda.tar.xz
testing/py-pykka: move to community
Diffstat (limited to 'community/py-pykka')
-rw-r--r--community/py-pykka/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/community/py-pykka/APKBUILD b/community/py-pykka/APKBUILD
new file mode 100644
index 0000000000..84284187c8
--- /dev/null
+++ b/community/py-pykka/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py-pykka
+pkgver=2.0.0
+pkgrel=0
+pkgdesc="Concurrency abstractions for Python using the actor model"
+url="https://pykka.readthedocs.org/"
+arch="noarch"
+license="Apache-2.0"
+depends="python2 python3"
+depends_dev=""
+makedepends="python2-dev python3-dev py-setuptools"
+install=""
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/P/Pykka/Pykka-$pkgver.tar.gz"
+
+builddir="$srcdir"/Pykka-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="f45789fe8e86f95bbff2e69b3e14d46ff25de400147e1d72fc766188975f66efbe00238fc56e36b5e0c1716369d15d236759be1adf69e01ef9b81ef443d24852 Pykka-2.0.0.tar.gz"