aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-tempita
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-24 11:57:09 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-24 12:27:34 +0000
commitb23e701f4f66f0e0ef74f245e870230b0e3de52d (patch)
tree392399dbad244f73cd22702c2ec284f36dbe81c5 /community/py-tempita
parenta364914bfea200bd4d4ddab7450384f3302ae7bf (diff)
downloadaports-b23e701f4f66f0e0ef74f245e870230b0e3de52d.tar.bz2
aports-b23e701f4f66f0e0ef74f245e870230b0e3de52d.tar.xz
community/py-tempita: upgrade to 0.5.2, moved from testing. Added py2 subpackage
Diffstat (limited to 'community/py-tempita')
-rw-r--r--community/py-tempita/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/community/py-tempita/APKBUILD b/community/py-tempita/APKBUILD
new file mode 100644
index 0000000000..115c9d4df7
--- /dev/null
+++ b/community/py-tempita/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-tempita
+_pkgname=Tempita
+pkgver=0.5.2
+pkgrel=0
+pkgdesc="A small templating language"
+url="http://pythonpaste.org/tempita/"
+arch="noarch"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages="py2-${pkgname/py-/}:_py2"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python=$1
+ pkgdesc="$pkgdesc - $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ _py python2
+ replaces="$pkgname"
+}
+
+md5sums="4c2f17bb9d481821c41b6fbee904cea1 Tempita-0.5.2.tar.gz"
+sha256sums="cacecf0baa674d356641f1d406b8bff1d756d739c46b869a54de515d08e6fc9c Tempita-0.5.2.tar.gz"
+sha512sums="582d3ca35dfb2ad44491cf9e526db9f9c34c419f2b03a5ce86a7e5183f7760b380262367c062161d577c3fb3e69e39ee99bbf8e493873e1da1a350ef2f63630d Tempita-0.5.2.tar.gz"