aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-zope-component
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2019-01-26 15:29:37 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2019-01-26 21:22:57 +0000
commit58950a900052045a5547570e451f628a202f3992 (patch)
treeae2f8c477480dba93f5fa81454d675185bc55b0d /community/py-zope-component
parent8fbbf24adefedfeb489d7b5053c8704ee8326e2e (diff)
downloadaports-58950a900052045a5547570e451f628a202f3992.tar.bz2
aports-58950a900052045a5547570e451f628a202f3992.tar.xz
community/py-zope-component: add py3 support and fix deps
Diffstat (limited to 'community/py-zope-component')
-rw-r--r--community/py-zope-component/APKBUILD52
1 files changed, 42 insertions, 10 deletions
diff --git a/community/py-zope-component/APKBUILD b/community/py-zope-component/APKBUILD
index e1f5d8980f..fbd468f993 100644
--- a/community/py-zope-component/APKBUILD
+++ b/community/py-zope-component/APKBUILD
@@ -3,27 +3,59 @@
pkgname=py-zope-component
_pkgname=zope.component
pkgver=4.5
-pkgrel=0
+pkgrel=1
pkgdesc="Zope Component Architecture"
url="https://pypi.python.org/pypi/zope.component"
arch="noarch"
license="ZPL-2.1"
-depends="python2"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
+depends="
+ py-setuptools
+ py-zope-deferredimport
+ py-zope-deprecation
+ py-zope-event
+ py-zope-hookable
+ py-zope-interface
+ "
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="$_pkgname-$pkgver.tar.gz::https://github.com/zopefoundation/zope.component/archive/$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
- python2 setup.py build
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py test
+ python3 setup.py test
}
package() {
- cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir"
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
}
sha512sums="cca873bcb62b6eb60825c55fa8fe9704e505c9bec90f851921545d543c23e3995cc9d70ab9e7b8cc6b37853bbcffd09c93891f675ff113e68b56e23d8b28c912 zope.component-4.5.tar.gz"