aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-zope-deferredimport
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2019-01-26 15:25:20 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2019-01-26 21:12:19 +0000
commit9b6c0b7d9a65ac6e93c30b76c05b52cb3de19744 (patch)
tree74a558cb658af9e76dcb9e2dbd8088c53dde21cf /community/py-zope-deferredimport
parentd8450181e4a75eb4723d32a4f9da681a5ef92f6a (diff)
downloadaports-9b6c0b7d9a65ac6e93c30b76c05b52cb3de19744.tar.bz2
aports-9b6c0b7d9a65ac6e93c30b76c05b52cb3de19744.tar.xz
community/py-zope-deferredimport: new aport
this is added into community as its needed for certbot.
Diffstat (limited to 'community/py-zope-deferredimport')
-rw-r--r--community/py-zope-deferredimport/APKBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/community/py-zope-deferredimport/APKBUILD b/community/py-zope-deferredimport/APKBUILD
new file mode 100644
index 0000000000..03c757dd01
--- /dev/null
+++ b/community/py-zope-deferredimport/APKBUILD
@@ -0,0 +1,56 @@
+# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
+# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
+pkgname=py-zope-deferredimport
+_pkgname=zope.deferredimport
+pkgver=4.3
+pkgrel=0
+pkgdesc="Defer imports until used by code"
+url="https://github.com/zopefoundation/$_pkgname"
+arch="noarch"
+license="ZPL"
+depends="py-setuptools py-zope-proxy"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/zopefoundation/$_pkgname/archive/$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py test
+ python3 setup.py test
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+
+sha512sums="0b62cf6caa7709dbb6b0ae85bf9c5e24909c79af57da8e3d081e69ff9f73fc60fbe5a83cdfe795551eeee3c045d3783a09cb3e6eb3964a44e6fbbea149ca3f8a zope.deferredimport-4.3.tar.gz"