aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-zope-deprecation
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2019-01-26 15:22:16 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2019-01-26 21:12:19 +0000
commitd8450181e4a75eb4723d32a4f9da681a5ef92f6a (patch)
treefaffc751e7d5ab857b59be0095020aa928010922 /community/py-zope-deprecation
parent6cfc6137d7936ef4e37fa4ca269b560a001936ca (diff)
downloadaports-d8450181e4a75eb4723d32a4f9da681a5ef92f6a.tar.bz2
aports-d8450181e4a75eb4723d32a4f9da681a5ef92f6a.tar.xz
community/py-zope-deprecation: upgrade move and add py3 support
- upgrade to 4.4.0 - move from testing to commnity - add support for python3
Diffstat (limited to 'community/py-zope-deprecation')
-rw-r--r--community/py-zope-deprecation/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/community/py-zope-deprecation/APKBUILD b/community/py-zope-deprecation/APKBUILD
new file mode 100644
index 0000000000..fdfad1f05b
--- /dev/null
+++ b/community/py-zope-deprecation/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-zope-deprecation
+_pkgname=zope.deprecation
+pkgver=4.4.0
+pkgrel=0
+pkgdesc="Zope Deprecation Infrastructure"
+url="https://pypi.python.org/pypi/zope.deprecation"
+arch="noarch"
+license="ZPL-2.1"
+depends="py-setuptools"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py test
+ python3 setup.py test
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="62371dc45fad6715f24cdcac1d25b559ed5248da774b5ecd215fb4d0b6fc0ab655bfb9e0fbceda964e8ffb7d70536e43f8fcf09d9f2742904717a6473869fa4a zope.deprecation-4.4.0.tar.gz"