aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-aiohttp
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-10-26 15:30:50 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-10-26 15:40:59 +0000
commit270bea15bc677f4b578318d21e1289dd5d07ef1c (patch)
tree9092c69ba9b252bab2ababd3b52d2cb54e43741a /community/py3-aiohttp
parentccc967e0f3d093a3fbaf9ad3cd5451d71fd0d9ec (diff)
downloadaports-270bea15bc677f4b578318d21e1289dd5d07ef1c.tar.bz2
aports-270bea15bc677f4b578318d21e1289dd5d07ef1c.tar.xz
community/py3-aiohttp: fix build in not x86 architectures
Manually remove _http_parser.cpython-36m-x86_64-linux-gnu.so shared object that is shipped in source code and make strip fails in not x86 architectures. Bug opened upstream: https://github.com/aio-libs/aiohttp/issues/2414
Diffstat (limited to 'community/py3-aiohttp')
-rw-r--r--community/py3-aiohttp/APKBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/community/py3-aiohttp/APKBUILD b/community/py3-aiohttp/APKBUILD
index 1c476171bf..fe203ae40c 100644
--- a/community/py3-aiohttp/APKBUILD
+++ b/community/py3-aiohttp/APKBUILD
@@ -19,6 +19,13 @@ check() {
python3 setup.py check
}
+prepare() {
+ default_prepare
+ # Workaround to remove x86_64 .so file that is shipped in source
+ # and make strip fails in arches != from x86_64
+ rm "$srcdir"/aiohttp-2.3.1/aiohttp/_http_parser.cpython-36m-x86_64-linux-gnu.so
+}
+
build() {
cd "$builddir"
python3 setup.py build