aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-aiohttp
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-11-22 03:28:05 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-11-22 03:28:05 +0000
commit824a938aabbc896aadd7c19ec811a27cccfc14ee (patch)
tree90982f9fd24d0cf7b6daba63d64e34e6b6fb67da /community/py3-aiohttp
parent1d1c1a08c93b6d889cf5751c60e1caac73ac5f13 (diff)
downloadaports-824a938aabbc896aadd7c19ec811a27cccfc14ee.tar.bz2
aports-824a938aabbc896aadd7c19ec811a27cccfc14ee.tar.xz
community/py3-aiohttp: enabled aarch arch
Diffstat (limited to 'community/py3-aiohttp')
-rw-r--r--community/py3-aiohttp/APKBUILD19
1 files changed, 6 insertions, 13 deletions
diff --git a/community/py3-aiohttp/APKBUILD b/community/py3-aiohttp/APKBUILD
index 4084674541..f51f4d8406 100644
--- a/community/py3-aiohttp/APKBUILD
+++ b/community/py3-aiohttp/APKBUILD
@@ -3,10 +3,10 @@
pkgname=py3-aiohttp
_pkgname=aiohttp
pkgver=2.3.3
-pkgrel=0
+pkgrel=1
pkgdesc="HTTP client/server for asyncio"
url="https://pypi.python.org/pypi/aiohttp"
-arch="all !aarch64"
+arch="all"
license="ASL 2.0"
depends="python3 py3-async-timeout py3-chardet py3-multidict py3-yarl"
makedepends="python3-dev"
@@ -14,21 +14,14 @@ subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
-check() {
+build() {
cd "$builddir"
- python3 setup.py check
+ python3 setup.py build
}
-#prepare() {
-# default_prepare
-# # Workaround to remove x86_64 .so file that is shipped in source
-# # and make strip fails in arches != from x86_64
-# rm "$srcdir"/$_pkgname-$pkgver/aiohttp/_http_parser.cpython-36m-x86_64-linux-gnu.so
-#}
-
-build() {
+check() {
cd "$builddir"
- python3 setup.py build
+ python3 setup.py check
}
package() {