aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-asn1-modules
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-16 02:48:47 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-02 01:43:47 +0000
commitaad2afe051973fa7fd6f4f9b83703c09445ff17c (patch)
tree4266144bb0c3984f784b0dd910d33fa98a72c353 /community/py3-asn1-modules
parentaad758e364da9a69d0d519b619cc6eb2c7d150f8 (diff)
downloadaports-aad2afe051973fa7fd6f4f9b83703c09445ff17c.tar.bz2
aports-aad2afe051973fa7fd6f4f9b83703c09445ff17c.tar.xz
community/py3-*: move from main/ and modernize
Diffstat (limited to 'community/py3-asn1-modules')
-rw-r--r--community/py3-asn1-modules/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/py3-asn1-modules/APKBUILD b/community/py3-asn1-modules/APKBUILD
new file mode 100644
index 0000000000..a261b7d6d0
--- /dev/null
+++ b/community/py3-asn1-modules/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-asn1-modules
+_pkgname=pyasn1-modules
+pkgver=0.2.7
+pkgrel=1
+pkgdesc="A collection of ASN.1-based protocols modules"
+url="https://pypi.python.org/pypi/pyasn1-modules"
+arch="noarch"
+license="BSD-2-Clause"
+depends="py3-asn1<0.5.0"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+replaces="py-asn1-modules" # Backwards compatibility
+provides="py-asn1-modules=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="5854cb2eebe7ef7eaae701fba8c8b847f84115c699037d9cd29ddbfb8f0142172031155404d34f004a454227659b8726631f0e3082c856f6311544148768655f pyasn1-modules-0.2.7.tar.gz"