aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-attrs
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2018-05-02 16:38:34 +0200
committerFrancesco Colista <fcolista@alpinelinux.org>2018-05-08 13:42:46 +0000
commit313ebbf01c1bea6409f059ead53c006fb52d8281 (patch)
tree195a1ccd4b51912e1f0b90e7f42139cbdde2a43b /community/py3-attrs
parent93bb13a8626de0b8eeb512c70feff5363d363924 (diff)
downloadaports-313ebbf01c1bea6409f059ead53c006fb52d8281.tar.bz2
aports-313ebbf01c1bea6409f059ead53c006fb52d8281.tar.xz
community/py-attrs: renamed from py3-attrs
Diffstat (limited to 'community/py3-attrs')
-rw-r--r--community/py3-attrs/APKBUILD29
-rw-r--r--community/py3-attrs/check.py10
2 files changed, 0 insertions, 39 deletions
diff --git a/community/py3-attrs/APKBUILD b/community/py3-attrs/APKBUILD
deleted file mode 100644
index 9a8070c466..0000000000
--- a/community/py3-attrs/APKBUILD
+++ /dev/null
@@ -1,29 +0,0 @@
-# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
-# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
-pkgname=py3-attrs
-pkgver=17.4.0
-pkgrel=0
-pkgdesc="Python classes without boilerplate"
-url="http://www.attrs.org"
-arch="noarch"
-license="MIT"
-depends="python3"
-makedepends="python3-dev py3-pytest py3-setuptools"
-source="py3-attrs-$pkgver.tar.gz::https://github.com/python-attrs/attrs/archive/$pkgver.tar.gz"
-builddir="$srcdir/attrs-$pkgver"
-
-build() {
- cd "$builddir"
- python3 setup.py build
-}
-
-check() {
- PYTHONPATH="$builddir/src" python3 check.py
-}
-
-package() {
- cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="14a512009cefbadc66972380f3beeb80e28daebeef467838c3506fd33a65e555666434a2d8f7294291b431e8b787aea370e267045f30a2253463e79d0e6caa3a py3-attrs-17.4.0.tar.gz"
diff --git a/community/py3-attrs/check.py b/community/py3-attrs/check.py
deleted file mode 100644
index 08af9829fb..0000000000
--- a/community/py3-attrs/check.py
+++ /dev/null
@@ -1,10 +0,0 @@
-import attr
-
-@attr.s
-class SomeClass(object):
- a_number = attr.ib(default=42)
- list_of_numbers = attr.ib(default=attr.Factory(list))
-
-a = SomeClass()
-assert a.a_number == 42
-assert isinstance(a.list_of_numbers, list)