aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-click-plugins
diff options
context:
space:
mode:
authorHolger Jaekel <holger.jaekel@gmx.de>2020-05-06 19:52:02 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-05-07 19:27:02 +0200
commit1bed0098556599249c4f75313dc53ea5b7ccf6b5 (patch)
tree3390b01c432651fec77aa45330923b4e71d30b96 /community/py3-click-plugins
parent5f6a30b7ac015c1069cec823e6ff81b8c9f640ba (diff)
downloadaports-1bed0098556599249c4f75313dc53ea5b7ccf6b5.tar.bz2
aports-1bed0098556599249c4f75313dc53ea5b7ccf6b5.tar.xz
community/py3-click-plugins: move from testing
Diffstat (limited to 'community/py3-click-plugins')
-rw-r--r--community/py3-click-plugins/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/py3-click-plugins/APKBUILD b/community/py3-click-plugins/APKBUILD
new file mode 100644
index 0000000000..0d247fb50c
--- /dev/null
+++ b/community/py3-click-plugins/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Holger Jaekel <holger.jaekel@gmx.de>
+# Maintainer: Holger Jaekel <holger.jaekel@gmx.de>
+_pkgname=click-plugins
+pkgname=py3-$_pkgname
+pkgver=1.1.1
+pkgrel=0
+pkgdesc="An extension module for click to enable registering CLI commands via setuptools entry-points"
+url="https://pypi.org/project/click-plugins/"
+arch="noarch"
+license="BSD-3-Clause"
+depends="
+ python3
+ py3-click
+ "
+checkdepends="
+ pytest
+ "
+source="
+ py3-click-plugins-$pkgver.tar.gz::https://github.com/click-contrib/click-plugins/archive/$pkgver.tar.gz
+ "
+builddir="$srcdir/click-plugins-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ pytest-3
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=2
+}
+
+sha512sums="a1735f493aad45b328e3156b239376be89ae8bc9d1cd349355496352157672b6642429e0fe7e364c0e971c5f347263cfb6481f413185ad869173c2777679a37e py3-click-plugins-1.1.1.tar.gz"