aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-deprecated/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2020-01-02 16:13:37 +0100
committerJakub Jirutka <jakub@jirutka.cz>2020-01-02 16:14:29 +0100
commita1ecfe2bce21c5905866578b600dc27184245e88 (patch)
treeadc23c6295f8ab72475839de72cf445d455c75c5 /community/py3-deprecated/APKBUILD
parentf436aae86ffeb256979cb26842bb05fd3a5a7b35 (diff)
downloadaports-a1ecfe2bce21c5905866578b600dc27184245e88.tar.bz2
aports-a1ecfe2bce21c5905866578b600dc27184245e88.tar.xz
community/py3-deprecated: move from testing
Diffstat (limited to 'community/py3-deprecated/APKBUILD')
-rw-r--r--community/py3-deprecated/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/py3-deprecated/APKBUILD b/community/py3-deprecated/APKBUILD
new file mode 100644
index 0000000000..827cffeda6
--- /dev/null
+++ b/community/py3-deprecated/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-deprecated
+pkgver=1.2.7
+pkgrel=0
+pkgdesc="@deprecated decorator to deprecate old python classes, functions or methods."
+url="https://github.com/tantale/deprecated"
+arch="noarch"
+license="MIT"
+depends="python3 py3-wrapt<2"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-pytest-cov"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tantale/deprecated/archive/v$pkgver.tar.gz"
+builddir="$srcdir/deprecated-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 -m pytest
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="da99a22410fdcc2a96cb5b15c489971078ce34e251406ae3dce6b3f97e284a4f09aaf1c5702407abe85a94cb6c8d9237f373a3096d6182e4a9cd1990be2817f1 py3-deprecated-1.2.7.tar.gz"