aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-dicttoxml
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-08-15 20:05:52 +0300
committerprspkt <prspkt@protonmail.com>2019-08-15 20:08:44 +0300
commitd9897b8b2727d090805ea4a945f5ae4baf8356fe (patch)
tree42a060903a3768c411b8b08098becfd7a66449f8 /community/py3-dicttoxml
parentd71c6bb78d079298030cd6acfb3d125715335f7b (diff)
downloadaports-d9897b8b2727d090805ea4a945f5ae4baf8356fe.tar.bz2
aports-d9897b8b2727d090805ea4a945f5ae4baf8356fe.tar.xz
community/py-dicttoxml: drop python2
Signed-off-by: prspkt <prspkt@protonmail.com>
Diffstat (limited to 'community/py3-dicttoxml')
-rw-r--r--community/py3-dicttoxml/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/py3-dicttoxml/APKBUILD b/community/py3-dicttoxml/APKBUILD
new file mode 100644
index 0000000000..2405b597dd
--- /dev/null
+++ b/community/py3-dicttoxml/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py3-dicttoxml
+_pkgname=dicttoxml
+pkgver=1.7.4
+pkgrel=3
+pkgdesc="Converts a Python dictionary or other native data type into a valid XML string"
+url="https://github.com/quandyfactory/dicttoxml"
+arch="noarch"
+license="GPL-2.0-only"
+depends="python3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+options="!check" # No test suite
+
+replaces=py-dicttoxml # Backwards compatibility
+provides=py-dicttoxml=$pkgver-r$pkgrel # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="91abcf2b9b248717618e9fc1c8694e881b9deaa16438dd4674f94a22b4aabfdab3b13f95c3d44a60577d49eca82fb268f59b33d1312cf5388bdaf949a2865cbf dicttoxml-1.7.4.tar.gz"