aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-distutils-extra/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-29 13:32:42 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-29 14:41:50 -0300
commitef52b9c0e17893cc3676f815af9b8887b62aeb33 (patch)
tree38be390b40e46e0ec18ffd866e93693301a21665 /community/py3-distutils-extra/APKBUILD
parent855f681ab624ceac8bada45b0ca04090d1dacb3a (diff)
downloadaports-ef52b9c0e17893cc3676f815af9b8887b62aeb33.tar.bz2
aports-ef52b9c0e17893cc3676f815af9b8887b62aeb33.tar.xz
community/py3-distutils-extra: rename from py-distutils-extra
Diffstat (limited to 'community/py3-distutils-extra/APKBUILD')
-rw-r--r--community/py3-distutils-extra/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/community/py3-distutils-extra/APKBUILD b/community/py3-distutils-extra/APKBUILD
new file mode 100644
index 0000000000..99525d6710
--- /dev/null
+++ b/community/py3-distutils-extra/APKBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=py-distutils-extra
+_pkgname=python-distutils-extra
+pkgver=2.39
+pkgrel=5
+pkgdesc="Enhanced distutils package for python"
+url="https://launchpad.net/python-distutils-extra"
+arch="noarch"
+license="GPL-2.0-or-later"
+depends="py-setuptools"
+makedepends="py2-setuptools py3-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://launchpad.net/python-distutils-extra/trunk/$pkgver/+download/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ python2 setup.py check
+ python3 setup.py check
+}
+
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ depends="${depends//py-/py2-}"
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="e3b4d1ed22767fb4c6dbbdccef960865b6fda01d18dc38cb8f9357c09c7eabb78466fce053e407a196eca257d07d57c5c1ef47f358a5979c7f22e4b11775124e python-distutils-extra-2.39.tar.gz"