aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-eliot
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-06 20:59:51 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-06 20:59:51 +0100
commitb3490f59187aab9b21e13756438d6428151171c2 (patch)
treebe0f6a8b59a5b6ec7d747257e477b2e9f4500fb4 /community/py3-eliot
parent8f205109bc61b25e86e059a8740f8d09cc9011e6 (diff)
downloadaports-b3490f59187aab9b21e13756438d6428151171c2.tar.bz2
aports-b3490f59187aab9b21e13756438d6428151171c2.tar.xz
community/py3-eliot: move from testing
Diffstat (limited to 'community/py3-eliot')
-rw-r--r--community/py3-eliot/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/py3-eliot/APKBUILD b/community/py3-eliot/APKBUILD
new file mode 100644
index 0000000000..afc4135661
--- /dev/null
+++ b/community/py3-eliot/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-eliot
+pkgver=1.10.0
+pkgrel=1
+pkgdesc="Logging system that tells you why it happened"
+# Requires unpackaged dask and cffi for testing journald
+options="!check"
+url="https://github.com/itamarst/eliot"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-six py3-zope-interface py3-pyrsistent py3-boltons
+ py3-twisted"
+makedepends="py3-setuptools"
+checkdepends="py3-hypothesis py3-testtools py3-pytest"
+source="$pkgname-$pkgver.tar.gz::https://github.com/itamarst/eliot/archive/$pkgver.tar.gz"
+builddir="$srcdir/eliot-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="69cf85d629b9f69c7077cdd7cf1eafdf743f68c949777d9c9c86c7bc26342f07f78dc9171a6173aabe4b88c3e8a133f5b9303b1dcf8eab9d63916850b17ae24a py3-eliot-1.10.0.tar.gz"