aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-faker
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-25 22:31:32 +0300
committerprspkt <prspkt@protonmail.com>2019-06-28 00:40:47 +0300
commitb436a89f03d207ea36461d094a0c609f16747cad (patch)
tree5d887235da62d6ffc9f2a3346de95ab4ca3ca4ef /community/py3-faker
parentce172b140d595228ab1a02fc11cb2a7fa80a7a53 (diff)
downloadaports-b436a89f03d207ea36461d094a0c609f16747cad.tar.bz2
aports-b436a89f03d207ea36461d094a0c609f16747cad.tar.xz
community/py3-faker: modernize
Diffstat (limited to 'community/py3-faker')
-rw-r--r--community/py3-faker/APKBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/community/py3-faker/APKBUILD b/community/py3-faker/APKBUILD
index 671d3ddcd2..a1aa94a8e0 100644
--- a/community/py3-faker/APKBUILD
+++ b/community/py3-faker/APKBUILD
@@ -1,35 +1,33 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-faker
-_pkgname=Faker
+_pyname=Faker
pkgver=1.0.4
pkgrel=1
pkgdesc="Python package that generates fake data for you"
-url=https://faker.readthedocs.io/en/master/
-arch=noarch
-license=MIT
+url="https://faker.readthedocs.io/en/master"
+arch="noarch"
+license="MIT"
depends="py3-dateutil py3-setuptools py3-six py3-text-unidecode"
checkdepends="py3-email-validator py3-ipaddress py3-mock py3-more-itertools
py3-pytest py3-ukpostcodeparser"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir=$srcdir/$_pkgname-$pkgver
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir=$srcdir/$_pyname-$pkgver
replaces="py-faker" # Backwards compatibility
provides="py-faker=$pkgver-r$pkgrel" # Backwards compatibility
prepare() {
- cd "$builddir"
- # They erroneously require a specific version of pytest
+ default_prepare
+ # tests erroneously require a specific version of pytest
sed -i setup.py -e 's/ *"pytest>=.*//g'
- cp -r "$builddir" "$builddir"-py3
}
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
python3 setup.py test
}