aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-fakeredis
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2019-06-10 14:43:15 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-06-11 06:02:18 +0000
commit20ff24801a1ac41ddf3ea2f6bdaddd5f22e3c243 (patch)
tree706a5d83b9cc1cee6f47d96e597fca8edfff0cee /community/py3-fakeredis
parent7f3533e7423d9f8e56408d338c8e9313e724b6ba (diff)
downloadaports-20ff24801a1ac41ddf3ea2f6bdaddd5f22e3c243.tar.bz2
aports-20ff24801a1ac41ddf3ea2f6bdaddd5f22e3c243.tar.xz
community/py3-fakeredis: moved from testing
Diffstat (limited to 'community/py3-fakeredis')
-rw-r--r--community/py3-fakeredis/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/py3-fakeredis/APKBUILD b/community/py3-fakeredis/APKBUILD
new file mode 100644
index 0000000000..5d45fe05e5
--- /dev/null
+++ b/community/py3-fakeredis/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=py3-fakeredis
+_pkgname=${pkgname#py3-}
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="Fake implementation of redis API for testing purposes"
+url="https://pypi.org/project/fakeredis/"
+arch="noarch"
+license="BSD-3-Clause"
+makedepends="python3-dev"
+depends="python3 py3-six py3-redis py3-sortedcontainers"
+checkdepends="py3-redis py3-six py3-nose py3-sortedcontainers py3-lupa"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH=. python3 test_fakeredis.py
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="8e91b1d6bd08816d20d313ae234f59f974655026cb52ae27c42ee7cb540855206f37fd6ccbe12ebfc07ebdf737f473217a934a80657f720db0053ebdf735cf99 py3-fakeredis-1.0.3.tar.gz"