aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-fido2/APKBUILD
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-03-02 10:13:58 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-03-02 10:46:03 +0100
commit376559ce1003d7fc4647a0bc3a362070bed3c474 (patch)
tree9abd06f3cc2683801a90e49f3fffae342d43bb66 /community/py3-fido2/APKBUILD
parent5cb6c88a27f67df3e1d964ea230764083236aed7 (diff)
downloadaports-376559ce1003d7fc4647a0bc3a362070bed3c474.tar.bz2
aports-376559ce1003d7fc4647a0bc3a362070bed3c474.tar.xz
community/py3-fido2: move from testing
Diffstat (limited to 'community/py3-fido2/APKBUILD')
-rw-r--r--community/py3-fido2/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/py3-fido2/APKBUILD b/community/py3-fido2/APKBUILD
new file mode 100644
index 0000000000..10484b9951
--- /dev/null
+++ b/community/py3-fido2/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Daniel Everett <deverett@gmail.com>
+# Maintainer: Daniel Everett <deverett@gmail.com>
+pkgname=py3-fido2
+_pkgname=${pkgname#py3-}
+pkgver=0.8.1
+pkgrel=0
+pkgdesc="Provides library functionality for FIDO 2.0, including communication with a device over USB"
+url="https://developers.yubico.com/python-fido2/"
+arch="noarch"
+license="BSD-2-Clause AND Apache-2.0 AND MPL-2.0"
+depends="py3-cryptography py3-six"
+makedepends="py3-setuptools"
+checkdepends="py3-cparser py3-mock"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+check() {
+ # Requires downloading 'pyfakefs' module
+ touch "test/__init__.py"
+ python3 setup.py test
+}
+
+sha512sums="fc0753ea694f2170d529129764cd9f9c5439cd2f467e4f384d7a698266ee8391a5c9c7c6e51d2dc2a99b93fca1c7d5288d5236e302672a87b8ca7704f328c0b5 fido2-0.8.1.tar.gz"