aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-flask-login
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 22:03:52 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 14:50:15 -0300
commit31e70b6cfd7b23e9f4106b8eba2eb15ff48dbff4 (patch)
treeaf8675242f3a05f3febe7e599fe599b78158ab05 /community/py3-flask-login
parent69778f82d93a6acbede5b70ce60407e56787063b (diff)
downloadaports-31e70b6cfd7b23e9f4106b8eba2eb15ff48dbff4.tar.bz2
aports-31e70b6cfd7b23e9f4106b8eba2eb15ff48dbff4.tar.xz
community/py3-flask-login: rename from py-flask-login
Diffstat (limited to 'community/py3-flask-login')
-rw-r--r--community/py3-flask-login/APKBUILD70
1 files changed, 70 insertions, 0 deletions
diff --git a/community/py3-flask-login/APKBUILD b/community/py3-flask-login/APKBUILD
new file mode 100644
index 0000000000..531e4f0caa
--- /dev/null
+++ b/community/py3-flask-login/APKBUILD
@@ -0,0 +1,70 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Contributor:
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=py-flask-login
+_pkgname=Flask-Login
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="Flask user session management"
+url="https://pypi.python.org/pypi/Flask-Login"
+arch="noarch"
+license="BSD"
+makedepends="
+ py-setuptools
+ py2-flask
+ py2-nose
+ py3-flask
+ py3-nose
+ python2-dev
+ python3-dev
+"
+subpackages="py2-flask-login:py2 py3-flask-login:py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+prepare() {
+ cp -r "$builddir" "$builddir"-py2
+ cp -r "$builddir" "$builddir"-py3
+}
+
+build() {
+ cd "$builddir"-py2
+ python2 setup.py build
+ cd "$builddir"-py3
+ python3 setup.py build
+}
+
+check() {
+ py2ver=$(python2 --version 2>&1 | cut -d' ' -f2 | cut -d. -f1-2)
+ py3ver=$(python3 --version 2>&1 | cut -d' ' -f2 | cut -d. -f1-2)
+ cd "$builddir"-py2
+ nosetests-$py2ver
+ cd "$builddir"-py3
+ nosetests-$py3ver
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ python="$1"
+ pkgdesc="$pkgdesc ${python#python}"
+ depends="$depends $python py${python#python}-flask"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+py2() {
+ cd "$builddir"-py2
+ _py python2
+}
+
+py3() {
+ cd "$builddir"-py3
+ _py python3
+}
+
+sha512sums="e57c80647e5504adb302490e6497165952a45c4bb211836bbd8bc2932ee19073bf7a8635ea4928ab83b9ae630617d3309089e62eaf07442ab094e9b1559b151f Flask-Login-0.4.1.tar.gz"