aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-gitlab/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-27 05:07:16 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-27 10:11:49 +0000
commit381b0d65e328d1233cea8bb059df8732a11bd312 (patch)
tree37bdd69593557bd05ddfbfd2f6bfcce3f58a58af /community/py3-gitlab/APKBUILD
parenta1ac96380425900c22eca97c2422f7f7bdf20ade (diff)
downloadaports-381b0d65e328d1233cea8bb059df8732a11bd312.tar.bz2
aports-381b0d65e328d1233cea8bb059df8732a11bd312.tar.xz
community/py3-gitlab: move from testing
Diffstat (limited to 'community/py3-gitlab/APKBUILD')
-rw-r--r--community/py3-gitlab/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/py3-gitlab/APKBUILD b/community/py3-gitlab/APKBUILD
new file mode 100644
index 0000000000..e8963f4d70
--- /dev/null
+++ b/community/py3-gitlab/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer:
+pkgname=py3-gitlab
+_pkgname=python-gitlab
+pkgver=2.1.2
+pkgrel=0
+pkgdesc="v4 GitLab API compliant library and cmdline tool"
+options="!check" # Requires unpackaged 'httmock'
+url="https://github.com/python-gitlab/python-gitlab"
+arch="noarch"
+license="LGPL-3.0-or-later"
+depends="python3 py3-requests py3-six"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-mock"
+source="https://files.pythonhosted.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ py.test-3
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="9d139a4fc21b02f9d0640fcd88528a42a51c29ab20802f476744b30cc85c174f91c2514f8aca0d5b0b45b494510e2a606a5e7a7edbc68cda7bdcd0636669e6ea python-gitlab-2.1.2.tar.gz"