aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-giturlparse
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-18 15:17:30 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-18 19:32:33 +0000
commitc0854132a0610ef72e5251fd99736b22bc882bad (patch)
tree4b4395e63d3c8c40eb4dba99ef14ec2a5b1eb52e /community/py3-giturlparse
parentb6c18774d963bfcf1de065a713238b5ad35cef38 (diff)
downloadaports-c0854132a0610ef72e5251fd99736b22bc882bad.tar.bz2
aports-c0854132a0610ef72e5251fd99736b22bc882bad.tar.xz
community/py3-giturlparse: move from testing
Diffstat (limited to 'community/py3-giturlparse')
-rw-r--r--community/py3-giturlparse/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/py3-giturlparse/APKBUILD b/community/py3-giturlparse/APKBUILD
new file mode 100644
index 0000000000..e9b8b1f090
--- /dev/null
+++ b/community/py3-giturlparse/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-giturlparse
+pkgver=0.9.2
+pkgrel=0
+pkgdesc="Parse and Rewrite git URLs"
+url="https://github.com/nephila/giturlparse"
+arch="noarch"
+license="Apache-2.0"
+depends="python3"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/nephila/giturlparse/archive/0.9.2.tar.gz"
+builddir="$srcdir/giturlparse-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+ rm -rf "$pkgdir"/usr/lib/python3*/site-packages/tests
+}
+
+sha512sums="b82bb96f4b0a242364a0173b15fefc507dec85c176aa0fc679c4554f71ec6a11b18b8886e34b5ce080759d56070a9126f54167dda89be592db0f6df4728bfd4c py3-giturlparse-0.9.2.tar.gz"