aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-jedi
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-04-03 19:16:59 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-03 19:17:56 +0000
commitc7cf06844baec226ddcba5e33e93eb71f6fcbafc (patch)
tree2971f92b32ebd8adbfe3f7abe1d6de25f5d04817 /community/py3-jedi
parentea8e34b780aac7dd13c297fca892bed67c9c7bd2 (diff)
downloadaports-c7cf06844baec226ddcba5e33e93eb71f6fcbafc.tar.bz2
aports-c7cf06844baec226ddcba5e33e93eb71f6fcbafc.tar.xz
community/py-jedi: rename to py3-jedi
For now, all python3 related packages should be prefixed with py3-. When removing py2 support from this package, the original name was kept, but that is not standard.
Diffstat (limited to 'community/py3-jedi')
-rw-r--r--community/py3-jedi/APKBUILD36
-rw-r--r--community/py3-jedi/adjust-speed-test.patch15
2 files changed, 51 insertions, 0 deletions
diff --git a/community/py3-jedi/APKBUILD b/community/py3-jedi/APKBUILD
new file mode 100644
index 0000000000..8af611c8b8
--- /dev/null
+++ b/community/py3-jedi/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py3-jedi
+_pkgname=jedi
+pkgver=0.13.3
+pkgrel=0
+pkgdesc="Awesome autocompletion and static analysis library for python"
+url="https://pypi.org/project/jedi"
+arch="noarch"
+license="MIT"
+makedepends="py3-setuptools python3-dev"
+checkdepends="pytest py-parso py-tox"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ adjust-speed-test.patch"
+builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-jedi"
+provides="py-jedi"
+
+build() {
+ python3 setup.py build
+}
+
+_getpythonver(){
+ echo $(python3 -c 'import sys; print("{}{}".format(sys.version_info.major, sys.version_info.minor))')
+}
+
+check() {
+ tox -e py$(_getpythonver)
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="b20fc75d909f9b7c6db434f468e7cefd9768991ca72d7026df9c4000805675a979f9e40f75623770df44bf8919a46270bcaa8e28d991a2299c64bc4c60d873fc jedi-0.13.3.tar.gz
+8a33c01f8d9f4f121176b0346759e74ab9847f1803f9d82515826c470822bf35ca5c84c29ac0c65b244457f8a05e26e05f6182337eadaf2aa4acc80a88972e32 adjust-speed-test.patch"
diff --git a/community/py3-jedi/adjust-speed-test.patch b/community/py3-jedi/adjust-speed-test.patch
new file mode 100644
index 0000000000..0a95cacfec
--- /dev/null
+++ b/community/py3-jedi/adjust-speed-test.patch
@@ -0,0 +1,15 @@
+On aarch64, this tests takes ~0.4s, which is larger than the default
+threshold. Increase it a bit to let this test pass.
+diff --git a/test/test_speed.py b/test/test_speed.py
+index f3fa7c7b3d..ba5784acc8 100644
+--- a/test/test_speed.py
++++ b/test/test_speed.py
+@@ -30,7 +30,7 @@ def _check_speed(time_per_run, number=4, run_warm=True):
+ return decorated
+
+
+-@_check_speed(0.3)
++@_check_speed(0.5)
+ def test_os_path_join(Script):
+ s = "from posixpath import join; join('', '')."
+ assert len(Script(s).completions()) > 10 # is a str completion