aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-josepy
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-08-22 20:37:59 +0300
committerprspkt <prspkt@protonmail.com>2019-08-22 20:49:48 +0300
commit3c4e0a2bbfe5c6659c223feb88481e495d0ad68e (patch)
treefa43bcd064816918d9bbafcc089c90d81e38de9e /community/py3-josepy
parente617a1e69e8affd55bb7e2ea6b2bcb35cf8303ff (diff)
downloadaports-3c4e0a2bbfe5c6659c223feb88481e495d0ad68e.tar.bz2
aports-3c4e0a2bbfe5c6659c223feb88481e495d0ad68e.tar.xz
community/py-josepy: drop python2
Signed-off-by: prspkt <prspkt@protonmail.com>
Diffstat (limited to 'community/py3-josepy')
-rw-r--r--community/py3-josepy/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/py3-josepy/APKBUILD b/community/py3-josepy/APKBUILD
new file mode 100644
index 0000000000..b1bbb9a73e
--- /dev/null
+++ b/community/py3-josepy/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py3-josepy
+_pkgname=josepy
+pkgver=1.2.0
+pkgrel=2
+pkgdesc="JOSE protocol implementation in Python"
+url="https://github.com/jezdez/josepy"
+arch="noarch"
+license="Apache-2.0"
+depends="py3-cryptography py3-openssl py3-setuptools py3-six"
+makedepends="libffi-dev python3-dev"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/certbot/josepy/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+replaces=py-josepy # Backwards compatibility
+provides=py-josepy=$pkgver-r$pkgrel # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py check
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="25a360b3893e1c1c524440b02e0af66c6dfefd756cebdad1c27ae8a82461200448a9c8fc835747e160cbcbb63261a4f79d7765eaae5e0b19feea5bf84d5e8896 josepy-1.2.0.tar.gz"