aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-jsonschema-gns3/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-05-30 05:32:29 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-05-30 05:32:37 +0000
commitaad3153c4c451c5e2db615d9d0050b4e4bf617a9 (patch)
treee7c5dedb551115af039a49c9869bb2267ea15d13 /community/py3-jsonschema-gns3/APKBUILD
parent4abb588c662e7cbe07c3585e215be73d836c08d3 (diff)
downloadaports-aad3153c4c451c5e2db615d9d0050b4e4bf617a9.tar.bz2
aports-aad3153c4c451c5e2db615d9d0050b4e4bf617a9.tar.xz
community/py3-jsonschema-gns3: new aport, dependency of GNS3
(gns3-server)
Diffstat (limited to 'community/py3-jsonschema-gns3/APKBUILD')
-rw-r--r--community/py3-jsonschema-gns3/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/py3-jsonschema-gns3/APKBUILD b/community/py3-jsonschema-gns3/APKBUILD
new file mode 100644
index 0000000000..0a6551cffe
--- /dev/null
+++ b/community/py3-jsonschema-gns3/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py3-jsonschema-gns3
+_pkgname=jsonschema
+pkgver=2.6.0
+pkgrel=0
+pkgdesc="An implementation of JSON Schema validation for Python - GNS3 compatible version"
+url="https://github.com/Julian/jsonschema"
+arch="noarch"
+license="MIT"
+depends="py3-pyrsistent py-attrs !py3-jsonschema"
+makedepends="python3-dev"
+options="!check" # py3-twisted missing
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="03f916abd023b32fbe60f91718d6f2f94d8834bd1bd8ec85ab02f591a145161275c2cde25b037c4d2e94703b870159feb776d3556f011e4c394d2e20ab897b0b jsonschema-2.6.0.tar.gz"