aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-ldap3/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 23:22:32 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 09:36:11 -0300
commit80e2c9338f27f49e29403fd036577f54cbb84d58 (patch)
tree825bae40f015b7cfd096a3fb3f0e6446e6628175 /community/py3-ldap3/APKBUILD
parent033a680859f21eec452752238b2831b250ab00eb (diff)
downloadaports-80e2c9338f27f49e29403fd036577f54cbb84d58.tar.bz2
aports-80e2c9338f27f49e29403fd036577f54cbb84d58.tar.xz
community/py3-ldap3: drop py2
Diffstat (limited to 'community/py3-ldap3/APKBUILD')
-rw-r--r--community/py3-ldap3/APKBUILD35
1 files changed, 14 insertions, 21 deletions
diff --git a/community/py3-ldap3/APKBUILD b/community/py3-ldap3/APKBUILD
index d4f8c48113..c59bb31442 100644
--- a/community/py3-ldap3/APKBUILD
+++ b/community/py3-ldap3/APKBUILD
@@ -1,39 +1,32 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
-pkgname=py-ldap3
+pkgname=py3-ldap3
_pkgname=ldap3
pkgver=2.6
-pkgrel=0
-pkgdesc="A strictly RFC 4510 conforming LDAP V3 pure Python client"
+pkgrel=1
+pkgdesc="A strictly RFC 4510 conforming LDAP V3 pure Python3 client"
url="https://github.com/cannatag/ldap3"
arch="noarch"
-license="LGPL-3.0"
-depends="py-asn1"
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py2-$_pkgname:_subpackage py3-$_pkgname:_subpackage"
+license="LGPL-3.0-or-later"
+depends="python3 py3-asn1"
+makedepends="py3-setuptools"
source="$pkgname-$pkgver.tar.gz::https://github.com/cannatag/ldap3/archive/v$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
options="!check" # tests need running LDAP server
+replaces="py-ldap3" # Backwards compatibility
+provides="py-ldap3=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
-package() {
- mkdir -p "$pkgdir"
+check() {
+ python3 setup.py test
}
-_subpackage() {
- local pyver="${subpkgname:2:1}"
- local python="python$pyver"
- pkgdesc="$pkgdesc (for $python)"
- depends="$python ${depends//py-/py$pyver-}"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="1a1ded200f6c98a422f856b6b2295142acc8dc3b7bc2973c5cb8f54243d2769c5badc7707d965e51950610400c5fac2c823a543160e2bde405ea05fdb4aa8d91 py-ldap3-2.6.tar.gz"
+sha512sums="1a1ded200f6c98a422f856b6b2295142acc8dc3b7bc2973c5cb8f54243d2769c5badc7707d965e51950610400c5fac2c823a543160e2bde405ea05fdb4aa8d91 py3-ldap3-2.6.tar.gz"