aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-logilab-common
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 22:43:03 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 23:03:48 -0300
commiteb79b3e7abef17aa84712931327be98a622f244f (patch)
tree5f62691999a2799b63d1ea3716f0cd2d2abc8f37 /community/py3-logilab-common
parent1e2080120dbae93bcce400b37f165c4c2043c379 (diff)
downloadaports-eb79b3e7abef17aa84712931327be98a622f244f.tar.bz2
aports-eb79b3e7abef17aa84712931327be98a622f244f.tar.xz
community/py3-logilab-common: drop py2
Diffstat (limited to 'community/py3-logilab-common')
-rw-r--r--community/py3-logilab-common/APKBUILD39
1 files changed, 11 insertions, 28 deletions
diff --git a/community/py3-logilab-common/APKBUILD b/community/py3-logilab-common/APKBUILD
index 1ec56379d9..6005fd75a1 100644
--- a/community/py3-logilab-common/APKBUILD
+++ b/community/py3-logilab-common/APKBUILD
@@ -1,45 +1,28 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-logilab-common
+pkgname=py3-logilab-common
_pkgname=logilab-common
pkgver=1.4.1
-pkgrel=1
-pkgdesc="A collection of Python packages and modules used by Logilab projects"
+pkgrel=2
+pkgdesc="A collection of Python3 packages and modules used by Logilab projects"
+options="!check" # Tests depend on python2 only libs
url="https://www.logilab.org/project/logilab-common"
arch="noarch"
license="LGPL-2.0-or-later"
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+depends="python3 py3-six py3-setuptools"
+checkdepends="py3-pytest"
+source="http://download.logilab.org/pub/common/logilab-common-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-logilab-common" # Backwards compatibility
+provides="py-logilab-common=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="e016aa8bd8641b4178aa1d1dd58c8c78bf6c3a80c35c9096d9761eeb49c9ee1ab5952839a1b7ecc404cd60b31078d3e997d73ad4f8d07d88badffe6c8748a059 logilab-common-1.4.1.tar.gz"