aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-munkres
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-16 02:48:47 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-02 01:43:47 +0000
commitaad2afe051973fa7fd6f4f9b83703c09445ff17c (patch)
tree4266144bb0c3984f784b0dd910d33fa98a72c353 /community/py3-munkres
parentaad758e364da9a69d0d519b619cc6eb2c7d150f8 (diff)
downloadaports-aad2afe051973fa7fd6f4f9b83703c09445ff17c.tar.bz2
aports-aad2afe051973fa7fd6f4f9b83703c09445ff17c.tar.xz
community/py3-*: move from main/ and modernize
Diffstat (limited to 'community/py3-munkres')
-rw-r--r--community/py3-munkres/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/py3-munkres/APKBUILD b/community/py3-munkres/APKBUILD
new file mode 100644
index 0000000000..9b73594da6
--- /dev/null
+++ b/community/py3-munkres/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-munkres
+_pkgname=munkres
+pkgver=1.1.2
+pkgrel=1
+pkgdesc="Munkres algorithm for the assignment problem"
+url="http://software.clapper.org/munkres/"
+arch="noarch"
+license="BSD"
+makedepends="py3-setuptools"
+checkdepends="py3-nose"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/bmc/munkres/archive/release-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-release-$pkgver"
+
+replaces="py-munkres" # Backwards compatibility
+provides="py-munkres=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+
+sha512sums="4a8b698f53812303f5020b4fc357f859a63d97370fe311d16ae959addd9cacee65667e430cd0d00496e423c1f0c7a3c8d4219ba49600a982de323fadd2c03bec munkres-1.1.2.tar.gz"