aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-musicbrainzngs/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-16 02:48:47 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-02 01:43:47 +0000
commitaad2afe051973fa7fd6f4f9b83703c09445ff17c (patch)
tree4266144bb0c3984f784b0dd910d33fa98a72c353 /community/py3-musicbrainzngs/APKBUILD
parentaad758e364da9a69d0d519b619cc6eb2c7d150f8 (diff)
downloadaports-aad2afe051973fa7fd6f4f9b83703c09445ff17c.tar.bz2
aports-aad2afe051973fa7fd6f4f9b83703c09445ff17c.tar.xz
community/py3-*: move from main/ and modernize
Diffstat (limited to 'community/py3-musicbrainzngs/APKBUILD')
-rw-r--r--community/py3-musicbrainzngs/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/py3-musicbrainzngs/APKBUILD b/community/py3-musicbrainzngs/APKBUILD
new file mode 100644
index 0000000000..ad038bc84d
--- /dev/null
+++ b/community/py3-musicbrainzngs/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=py3-musicbrainzngs
+_pkgname=musicbrainzngs
+pkgver=0.7.1
+pkgrel=0
+pkgdesc="Bindings for the MusicBrainz NGS service"
+url="https://github.com/alastair/python-musicbrainzngs"
+arch="noarch"
+license="BSD-2-Clause AND ISC"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/m/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+replaces="py-musicbrainzngs" # Backwards compatibility
+provides="py-musicbrainzngs=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="df4a8aa184831301adae66f00638667a4a1c7124f61a7e00ef9051c33e35f2acf7aaf304ac4fcdf113566abd3164abe924f2cee91ca2015343b5bae308b91b9d musicbrainzngs-0.7.1.tar.gz"