aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-natsort/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-28 21:12:16 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-28 21:15:09 -0300
commit766f5765d51814c98fea8ac49ee427fb342d9e8f (patch)
tree825b181298344356b0e368ad23c84e4630d75808 /community/py3-natsort/APKBUILD
parent27297e1c17e0805d49406e4bca78ceed89d8bb38 (diff)
downloadaports-766f5765d51814c98fea8ac49ee427fb342d9e8f.tar.bz2
aports-766f5765d51814c98fea8ac49ee427fb342d9e8f.tar.xz
community/py3-natsort: upgrade to 6.0.0
Diffstat (limited to 'community/py3-natsort/APKBUILD')
-rw-r--r--community/py3-natsort/APKBUILD46
1 files changed, 13 insertions, 33 deletions
diff --git a/community/py3-natsort/APKBUILD b/community/py3-natsort/APKBUILD
index d5cfde04cf..e8b6d0f7e3 100644
--- a/community/py3-natsort/APKBUILD
+++ b/community/py3-natsort/APKBUILD
@@ -1,53 +1,33 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-natsort
+pkgname=py3-natsort
_pkgname=natsort
-pkgver=5.5.0
-pkgrel=1
+pkgver=6.0.0
+pkgrel=0
pkgdesc="A module for natural sorting"
+options="!check" # Locale related tests fail (7 out of 268)
url="https://github.com/SethMMorton/natsort"
arch="noarch"
license="MIT"
-# Dependencies to run tests are not ready yet
-options="!check"
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-hypothesis py3-pytest-mock"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-natsort" # Backwards compatibility
+provides="py-natsort=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
check() {
- cd "$builddir"
- pytest natsort
- pytest-3 natsort
+ python3 -m pytest
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="9d65c67bd9f441b1b0b16e048bc6ed6e9df21b8c18ae449ea0b86fec8c1c5a2f0d7bba0b8739481ed44ded1b5d692728ef1fca7c2b77cae272e729460d7eefed natsort-5.5.0.tar.gz"
+sha512sums="d051de6824a727ead814c0305beefaa61ee64038999187b95db5395c761f623077b086ef453c134668cb764f4fc5e72a767177442f6ac3d71ec9b491e8876d5b natsort-6.0.0.tar.gz"